summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2018-02-23 12:59:20 +0100
committerGordian Edenhofer2018-02-23 12:59:20 +0100
commit7b33cd7cd5d96696d07f8299a073068aea1d719e (patch)
treeb21e6514963dfa06273566809999b2fc05758cd6
parent3c4c5517aaedac6e722fa45ca8db8622cd2ca721 (diff)
downloadaur-7b33cd7cd5d96696d07f8299a073068aea1d719e.tar.gz
upgpkg: bcc 0.5.0-1
Remove 'bcc-git' from conflict array since the specification should be the other way around and fix one whitespacing mistake.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
2 files changed, 2 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f33d7fa029f..95ad6f80666a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,21 +14,19 @@ pkgbase = bcc
makedepends = bison
makedepends = python
makedepends = python2
- conflicts = bcc-git
source = https://github.com/iovisor/bcc/archive/v0.5.0.tar.gz
source = fix_build_issue_for_llvm_5.0.1.patch::https://github.com/iovisor/bcc/commit/bd7fa55bb39b8978dafd0b299e35616061e0a368.patch
sha512sums = 12de5ef04185dccd0847fc97ae855b386e0c81b545ae497af797667925ebedf97164c17fb99468abae3f87fb3ddfdba5200070f80b3bbcad63c2355497012f0e
sha512sums = 1c4a453a0663237b1ebebd4fdc60e7f6add8380bf624cfa6dd28e57a73d6db89b0a562c8bcaa788d8d59f69240b574b123d07e1eeb63da3a255d3b5e40c6221b
pkgname = bcc
- pkgdesc = BPF Compiler Collection -C library and examples
+ pkgdesc = BPF Compiler Collection - C library and examples
depends = linux-headers
optdepends = bcc-tools: Python utilites using the BCC library
optdepends = python-bcc: Python 3 bindings for BCC
optdepends = python2-bcc: Python 2 bindings for BCC
provides = bcc
provides = libbcc
- conflicts = bcc-git
pkgname = bcc-tools
pkgdesc = BPF Compiler Collection - Tools
@@ -36,18 +34,15 @@ pkgname = bcc-tools
depends = bcc
optdepends = python-bcc: Python 3 bindings for BCC
optdepends = python2-bcc: Python 2 bindings for BCC
- conflicts = bcc-tools-git
pkgname = python-bcc
pkgdesc = BPF Compiler Collection - Python 3 bindings
arch = any
depends = bcc
depends = python
- conflicts = python-bcc-git
pkgname = python2-bcc
pkgdesc = BPF Compiler Collection - Python 2 bindings
arch = any
depends = bcc
depends = python2
- conflicts = python2-bcc-git
diff --git a/PKGBUILD b/PKGBUILD
index f79140deaf72..73d008406431 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,6 @@ url='https://github.com/iovisor/bcc'
license=('Apache')
makedepends=('cmake' 'clang>=3.7.0' 'llvm>=3.7.0' 'flex' 'bison' 'python' 'python2')
checkdepends=('netperf' 'iperf')
-conflicts=('bcc-git')
source=("https://github.com/iovisor/${pkgname}/archive/v${pkgver}.tar.gz"
'fix_build_issue_for_llvm_5.0.1.patch::https://github.com/iovisor/bcc/commit/bd7fa55bb39b8978dafd0b299e35616061e0a368.patch')
sha512sums=('12de5ef04185dccd0847fc97ae855b386e0c81b545ae497af797667925ebedf97164c17fb99468abae3f87fb3ddfdba5200070f80b3bbcad63c2355497012f0e'
@@ -38,14 +37,13 @@ build() {
}
package_bcc() {
- pkgdesc='BPF Compiler Collection -C library and examples'
+ pkgdesc='BPF Compiler Collection - C library and examples'
depends=('linux-headers')
optdepends=('bcc-tools: Python utilites using the BCC library'
'python-bcc: Python 3 bindings for BCC'
'python2-bcc: Python 2 bindings for BCC')
makedepends=('cmake' 'clang>=3.7.0' 'llvm>=3.7.0' 'flex' 'bison')
provides=('bcc' 'libbcc')
- conflicts=('bcc-git')
cd "${srcdir}/${pkgbase}-${pkgver}/build"
@@ -65,7 +63,6 @@ package_bcc-tools() {
depends=('bcc')
optdepends=('python-bcc: Python 3 bindings for BCC'
'python2-bcc: Python 2 bindings for BCC')
- conflicts=('bcc-tools-git')
cd "${srcdir}/${pkgbase}-${pkgver}/build/tools"
make DESTDIR="${pkgdir}" install
@@ -80,7 +77,6 @@ package_python-bcc() {
arch=('any')
depends=('bcc' 'python')
makedepends=('cmake')
- conflicts=('python-bcc-git')
cd "${srcdir}/${pkgbase}-${pkgver}/build"
@@ -101,7 +97,6 @@ package_python2-bcc() {
arch=('any')
depends=('bcc' 'python2')
makedepends=('cmake')
- conflicts=('python2-bcc-git')
cd "${srcdir}/${pkgbase}-${pkgver}/build"