summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2018-02-15 22:26:40 +0100
committerGordian Edenhofer2018-02-15 22:33:44 +0100
commit7e196a0eacaca20ebf3a11620ec4949ee0065a80 (patch)
treedd9f5b75f8490b3a099ed734b0e7d5a534075116
parenteba87eba247349d996dce2523bfe2a6a7cd5e616 (diff)
downloadaur-7e196a0eacaca20ebf3a11620ec4949ee0065a80.tar.gz
upgpkg: bcc 0.3.0-1
* Use tabs everywhere (except checksums) * Use single quotes for literal strings without shell expanded keywords * Slightly reorder variables to honor the order of the ArchWiki article
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD158
2 files changed, 80 insertions, 83 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 48941594ef7d..9d5e076b008c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,3 @@
-# Generated by mksrcinfo v8
-# Mon Mar 13 23:59:55 UTC 2017
pkgbase = bcc
pkgdesc = BPF Compiler Collection
pkgver = 0.3.0
@@ -21,7 +19,7 @@ pkgbase = bcc
sha256sums = b28a2c5149394fb7402dad92e4c0552644b63dd41394569b966eceb96fc5477e
pkgname = bcc
- pkgdesc = BPF Compiler Collection - C library and examples
+ pkgdesc = BPF Compiler Collection -C library and examples
depends = linux-headers
optdepends = bcc-tools: Python utilites using the BCC library
optdepends = python-bcc: Python 3 bindings for BCC
@@ -48,4 +46,3 @@ pkgname = python2-bcc
depends = bcc
depends = python2
conflicts = python2-bcc-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 659644c57bc7..f7632218d363 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,111 +1,111 @@
-# Maintainer: Troy Engel <troyengel+arch@gmail.com>
+# Maintainer: Gordian Edenhofer <gordian.edenhofer@gmail.com>
+# Submitter: Troy Engel <troyengel+arch@gmail.com>
pkgbase=bcc
pkgname=('bcc' 'bcc-tools' 'python-bcc' 'python2-bcc')
pkgver=0.3.0
pkgrel=1
-pkgdesc="BPF Compiler Collection"
+pkgdesc='BPF Compiler Collection'
arch=('x86_64')
-url="https://github.com/iovisor/bcc"
+url='https://github.com/iovisor/bcc'
license=('Apache')
+makedepends=('cmake' 'clang>=3.7.0' 'llvm>=3.7.0' 'flex' 'bison' 'python' 'python2')
conflicts=('bcc-git')
-makedepends=('cmake' 'clang>=3.7.0' 'llvm>=3.7.0' 'flex' 'bison' 'python'
- 'python2')
source=("https://github.com/iovisor/${pkgname}/archive/v${pkgver}.tar.gz"
- 'cppex-0.3.0.patch')
+ 'cppex-0.3.0.patch')
sha256sums=('88f54dff96c30c6e7b45f475938eef790b1c9485f794b1ac6791c4e56007f7cc'
'b28a2c5149394fb7402dad92e4c0552644b63dd41394569b966eceb96fc5477e')
prepare() {
- # the provided CMakeLists.txt compiles the cpp examples with a static copy
- # of libbcc, ending up with ~282megs used; we'll just install the raw *.cc
- cd "${srcdir}"
- patch -p0 < "${srcdir}/cppex-0.3.0.patch"
+ # the provided CMakeLists.txt compiles the cpp examples with a static copy
+ # of libbcc, ending up with ~282megs used; we'll just install the raw *.cc
+ cd "${srcdir}"
+
+ patch -p0 < "${srcdir}/cppex-0.3.0.patch"
}
build() {
- # make sure repetitive builds are clean
- [[ -d "${srcdir}/${pkgbase}-${pkgver}/build" ]] && \
- rm -rf "${srcdir}/${pkgbase}-${pkgver}/build"
- mkdir "${srcdir}/${pkgbase}-${pkgver}/build"
- cd "${srcdir}/${pkgbase}-${pkgver}/build"
-
- # we don't care which python here for the core C library
- cmake .. -DREVISION=${pkgver} \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=/usr/lib
- make
+ # make sure repetitive builds are clean
+ [[ -d "${srcdir}/${pkgbase}-${pkgver}/build" ]] && \
+ rm -rf "${srcdir}/${pkgbase}-${pkgver}/build"
+ mkdir "${srcdir}/${pkgbase}-${pkgver}/build"
+ cd "${srcdir}/${pkgbase}-${pkgver}/build"
+
+ # we don't care which python here for the core C library
+ cmake .. -DREVISION=${pkgver} \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib
+ make
}
package_bcc() {
- pkgdesc="BPF Compiler Collection - C library and examples"
- makedepends=('cmake' 'clang>=3.7.0' 'llvm>=3.7.0' 'flex' 'bison')
- provides=('bcc' 'libbcc')
- conflicts=('bcc-git')
- depends=('linux-headers')
- optdepends=('bcc-tools: Python utilites using the BCC library'
- 'python-bcc: Python 3 bindings for BCC'
- 'python2-bcc: Python 2 bindings for BCC')
-
- # this installs the kitchen sink
- cd "${srcdir}/${pkgbase}-${pkgver}/build"
- make DESTDIR="${pkgdir}/" install
-
- # these go in a split package python*-bcc
- rm -rf "${pkgdir}"/usr/lib/python*
-
- # these go in a split package bcc-tools
- rm -rf "${pkgdir}"/usr/share/bcc/{tools,man}
+ pkgdesc='BPF Compiler Collection -C library and examples'
+ depends=('linux-headers')
+ optdepends=('bcc-tools: Python utilites using the BCC library'
+ 'python-bcc: Python 3 bindings for BCC'
+ 'python2-bcc: Python 2 bindings for BCC')
+ makedepends=('cmake' 'clang>=3.7.0' 'llvm>=3.7.0' 'flex' 'bison')
+ provides=('bcc' 'libbcc')
+ conflicts=('bcc-git')
+
+ # this installs the kitchen sink
+ cd "${srcdir}/${pkgbase}-${pkgver}/build"
+ make DESTDIR="${pkgdir}/" install
+
+ # these go in a split package python*-bcc
+ rm -rf "${pkgdir}"/usr/lib/python*
+
+ # these go in a split package bcc-tools
+ rm -rf "${pkgdir}"/usr/share/bcc/{tools,man}
}
package_bcc-tools() {
- pkgdesc="BPF Compiler Collection - Tools"
- depends=('bcc')
- conflicts=('bcc-tools-git')
- optdepends=('python-bcc: Python 3 bindings for BCC'
- 'python2-bcc: Python 2 bindings for BCC')
+ pkgdesc='BPF Compiler Collection - Tools'
+ depends=('bcc')
+ optdepends=('python-bcc: Python 3 bindings for BCC'
+ 'python2-bcc: Python 2 bindings for BCC')
+ conflicts=('bcc-tools-git')
- cd "${srcdir}/${pkgbase}-${pkgver}/build/tools"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/${pkgbase}-${pkgver}/build/tools"
+ make DESTDIR="${pkgdir}/" install
- cd "${srcdir}/${pkgbase}-${pkgver}/build/man"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/${pkgbase}-${pkgver}/build/man"
+ make DESTDIR="${pkgdir}/" install
}
package_python-bcc() {
- pkgdesc="BPF Compiler Collection - Python 3 bindings"
- makedepends=('cmake')
- depends=('bcc' 'python')
- conflicts=('python-bcc-git')
-
- # the C lib s already built, force a quick python3 binding build
- cd "${srcdir}/${pkgbase}-${pkgver}/build"
- cmake .. -DREVISION=${pkgver} -DPYTHON_CMD="python" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=/usr/lib
- make
-
- # now install just those bindings
- cd "${srcdir}/${pkgbase}-${pkgver}/build/src/python"
- make DESTDIR="${pkgdir}/" install
+ pkgdesc='BPF Compiler Collection - Python 3 bindings'
+ depends=('bcc' 'python')
+ makedepends=('cmake')
+ conflicts=('python-bcc-git')
+
+ # the C lib s already built, force a quick python3 binding build
+ cd "${srcdir}/${pkgbase}-${pkgver}/build"
+ cmake .. -DREVISION=${pkgver} -DPYTHON_CMD="python" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib
+ make
+
+ # now install just those bindings
+ cd "${srcdir}/${pkgbase}-${pkgver}/build/src/python"
+ make DESTDIR="${pkgdir}/" install
}
package_python2-bcc() {
- pkgdesc="BPF Compiler Collection - Python 2 bindings"
- makedepends=('cmake')
- depends=('bcc' 'python2')
- conflicts=('python2-bcc-git')
-
- # the C lib s already built, force a quick python2 binding build
- cd "${srcdir}/${pkgbase}-${pkgver}/build"
- cmake .. -DREVISION=${pkgver} -DPYTHON_CMD="python2" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=/usr/lib
- make
-
- # now install just those bindings
- cd "${srcdir}/${pkgbase}-${pkgver}/build/src/python"
- make DESTDIR="${pkgdir}/" install
+ pkgdesc='BPF Compiler Collection - Python 2 bindings'
+ depends=('bcc' 'python2')
+ makedepends=('cmake')
+ conflicts=('python2-bcc-git')
+
+ # the C lib s already built, force a quick python2 binding build
+ cd "${srcdir}/${pkgbase}-${pkgver}/build"
+ cmake .. -DREVISION=${pkgver} -DPYTHON_CMD="python2" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib
+ make
+
+ # now install just those bindings
+ cd "${srcdir}/${pkgbase}-${pkgver}/build/src/python"
+ make DESTDIR="${pkgdir}/" install
}
-