summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2018-06-14 21:03:59 +0200
committerGordian Edenhofer2018-06-14 21:03:59 +0200
commit81ead92dd2c3fef48afdd0bd3da9e3a871a158a2 (patch)
tree63dd0b53595cdfdcac5d28fefffe0792a723a5bc
parent0866bbbfd00a0c7b117ba9547aeaa9de1f1f6022 (diff)
downloadaur-81ead92dd2c3fef48afdd0bd3da9e3a871a158a2.tar.gz
upgpkg: bcc 0.6.0-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
2 files changed, 24 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c7b6c7e45d1..ef58758a2de0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bcc
pkgdesc = BPF Compiler Collection
- pkgver = 0.5.0
- pkgrel = 3
+ pkgver = 0.6.0
+ pkgrel = 1
url = https://github.com/iovisor/bcc
arch = x86_64
license = Apache
@@ -14,16 +14,13 @@ pkgbase = bcc
makedepends = bison
makedepends = python
makedepends = python2
- source = https://github.com/iovisor/bcc/archive/v0.5.0.tar.gz
- source = cherry-fix_build_issue_for_llvm_5.0.1.patch::https://github.com/iovisor/bcc/commit/bd7fa55bb39b8978dafd0b299e35616061e0a368.patch
- source = cherry-fix_a_compilation_error_with_latest_llvm_clang_trunk.patch::https://github.com/iovisor/bcc/commit/c0d1694e28336cbe4a57f420dd33c5e3bfaa2df9.patch
- sha512sums = 12de5ef04185dccd0847fc97ae855b386e0c81b545ae497af797667925ebedf97164c17fb99468abae3f87fb3ddfdba5200070f80b3bbcad63c2355497012f0e
- sha512sums = f518f32584b1f828af5df00972c33e6efc7f4327fd65505156e6dec96e4e2f6e7fafb50fb0855693d586223dce4f6cbf7db34ae252358636decc5dbe7f6121a7
- sha512sums = 04e1826388a47631c59ba027b04285665494ac417017f02fbed080be06fcc8ed352dbfedc28282dac0a7df637ed2c8614e6e4ce7f601a81afa741b24ba7fc85e
+ source = https://github.com/iovisor/bcc/archive/v0.6.0.tar.gz
+ sha512sums = 1a8edf6da22f3119a74cf43f03ec83b97ed2f6fc18828d750d8a695ac1451b6b3209e5d2cf48bc87f53fa9447e8813a018a58d31588d477e4aa364a2d0217e80
pkgname = bcc
pkgdesc = BPF Compiler Collection - C library and examples
depends = linux-headers
+ depends = libelf
optdepends = bcc-tools: Python utilites using the BCC library
optdepends = python-bcc: Python 3 bindings for BCC
optdepends = python2-bcc: Python 2 bindings for BCC
@@ -34,17 +31,24 @@ pkgname = bcc-tools
pkgdesc = BPF Compiler Collection - Tools
arch = any
depends = bcc
+ depends = libedit
+ depends = ethtool
optdepends = python-bcc: Python 3 bindings for BCC
optdepends = python2-bcc: Python 2 bindings for BCC
+ optdepends = luajit: Lua bindings for BCC
pkgname = python-bcc
pkgdesc = BPF Compiler Collection - Python 3 bindings
arch = any
depends = bcc
depends = python
+ optdepends = python-netaddr2: Network address representation and manipulation
+ optdepends = python-pyroute2: Netlink and Linux network configuration
pkgname = python2-bcc
pkgdesc = BPF Compiler Collection - Python 2 bindings
arch = any
depends = bcc
depends = python2
+ optdepends = python2-netaddr2: Network address representation and manipulation
+ optdepends = python2-pyroute2: Netlink and Linux network configuration
diff --git a/PKGBUILD b/PKGBUILD
index fd7dd7938717..d6e885f241e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,27 +3,16 @@
pkgbase=bcc
pkgname=('bcc' 'bcc-tools' 'python-bcc' 'python2-bcc')
-pkgver=0.5.0
-pkgrel=3
+pkgver=0.6.0
+pkgrel=1
pkgdesc='BPF Compiler Collection'
arch=('x86_64')
url='https://github.com/iovisor/bcc'
license=('Apache')
makedepends=('cmake' 'clang>=3.7.0' 'llvm>=3.7.0' 'flex' 'bison' 'python' 'python2')
checkdepends=('netperf' 'iperf')
-source=("https://github.com/iovisor/${pkgname}/archive/v${pkgver}.tar.gz"
- 'cherry-fix_build_issue_for_llvm_5.0.1.patch::https://github.com/iovisor/bcc/commit/bd7fa55bb39b8978dafd0b299e35616061e0a368.patch'
- 'cherry-fix_a_compilation_error_with_latest_llvm_clang_trunk.patch::https://github.com/iovisor/bcc/commit/c0d1694e28336cbe4a57f420dd33c5e3bfaa2df9.patch')
-sha512sums=('12de5ef04185dccd0847fc97ae855b386e0c81b545ae497af797667925ebedf97164c17fb99468abae3f87fb3ddfdba5200070f80b3bbcad63c2355497012f0e'
- 'f518f32584b1f828af5df00972c33e6efc7f4327fd65505156e6dec96e4e2f6e7fafb50fb0855693d586223dce4f6cbf7db34ae252358636decc5dbe7f6121a7'
- '04e1826388a47631c59ba027b04285665494ac417017f02fbed080be06fcc8ed352dbfedc28282dac0a7df637ed2c8614e6e4ce7f601a81afa741b24ba7fc85e')
-
-prepare() {
- cd "${srcdir}/${pkgbase}-${pkgver}"
-
- patch -Np1 -i "${srcdir}/cherry-fix_build_issue_for_llvm_5.0.1.patch"
- patch -Np1 -i "${srcdir}/cherry-fix_a_compilation_error_with_latest_llvm_clang_trunk.patch"
-}
+source=("https://github.com/iovisor/${pkgname}/archive/v${pkgver}.tar.gz")
+sha512sums=('1a8edf6da22f3119a74cf43f03ec83b97ed2f6fc18828d750d8a695ac1451b6b3209e5d2cf48bc87f53fa9447e8813a018a58d31588d477e4aa364a2d0217e80')
build() {
cd "${srcdir}/${pkgbase}-${pkgver}"
@@ -41,7 +30,7 @@ build() {
package_bcc() {
pkgdesc='BPF Compiler Collection - C library and examples'
- depends=('linux-headers')
+ depends=('linux-headers' 'libelf')
optdepends=('bcc-tools: Python utilites using the BCC library'
'python-bcc: Python 3 bindings for BCC'
'python2-bcc: Python 2 bindings for BCC')
@@ -63,9 +52,10 @@ package_bcc() {
package_bcc-tools() {
pkgdesc='BPF Compiler Collection - Tools'
arch=('any')
- depends=('bcc')
+ depends=('bcc' 'libedit' 'ethtool')
optdepends=('python-bcc: Python 3 bindings for BCC'
- 'python2-bcc: Python 2 bindings for BCC')
+ 'python2-bcc: Python 2 bindings for BCC'
+ 'luajit: Lua bindings for BCC')
cd "${srcdir}/${pkgbase}-${pkgver}/build/tools"
make DESTDIR="${pkgdir}" install
@@ -78,6 +68,8 @@ package_python-bcc() {
pkgdesc='BPF Compiler Collection - Python 3 bindings'
arch=('any')
depends=('bcc' 'python')
+ optdepends=('python-netaddr2: Network address representation and manipulation'
+ 'python-pyroute2: Netlink and Linux network configuration')
makedepends=('cmake')
cd "${srcdir}/${pkgbase}-${pkgver}/build"
@@ -98,6 +90,8 @@ package_python2-bcc() {
pkgdesc='BPF Compiler Collection - Python 2 bindings'
arch=('any')
depends=('bcc' 'python2')
+ optdepends=('python2-netaddr2: Network address representation and manipulation'
+ 'python2-pyroute2: Netlink and Linux network configuration')
makedepends=('cmake')
cd "${srcdir}/${pkgbase}-${pkgver}/build"