summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTroy Engel2016-01-24 13:37:53 -0600
committerTroy Engel2016-01-24 13:37:53 -0600
commita6eb08dc0a8087f228b90cf915e05a1e605faf6b (patch)
treeed6c841641c00348094e814fe9c862101277ee10
parent109328bf95268fb33d95fdcd57b608775885469f (diff)
downloadaur-a6eb08dc0a8087f228b90cf915e05a1e605faf6b.tar.gz
add conflicts for git packages
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD5
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29ff4b8c77d3..cae5d9b64345 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Jan 1 20:38:41 UTC 2016
+# Sun Jan 24 19:36:41 UTC 2016
pkgbase = bcc
pkgdesc = BPF Compiler Collection
pkgver = 0.1.7
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/iovisor/bcc
arch = x86_64
license = Apache
@@ -36,14 +36,17 @@ pkgname = bcc-tools
depends = bcc
optdepends = python-bcc: Python 3 bindings for BCC
optdepends = python2-bcc: Python 2 bindings for BCC
+ conflicts = bcc-tools-git
pkgname = python-bcc
pkgdesc = BPF Compiler Collection - Python 3 bindings
depends = bcc
depends = python
+ conflicts = python-bcc-git
pkgname = python2-bcc
pkgdesc = BPF Compiler Collection - Python 2 bindings
depends = bcc
depends = python2
+ conflicts = python2-bcc-git
diff --git a/PKGBUILD b/PKGBUILD
index c7e409915fd7..2e31bf46ae00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=bcc
pkgname=('bcc' 'bcc-tools' 'python-bcc' 'python2-bcc')
pkgver=0.1.7
-pkgrel=3
+pkgrel=4
pkgdesc="BPF Compiler Collection"
arch=('x86_64')
url="https://github.com/iovisor/bcc"
@@ -57,6 +57,7 @@ package_bcc() {
package_bcc-tools() {
pkgdesc="BPF Compiler Collection - Tools"
depends=('bcc')
+ conflicts=('bcc-tools-git')
optdepends=('python-bcc: Python 3 bindings for BCC'
'python2-bcc: Python 2 bindings for BCC')
@@ -75,6 +76,7 @@ package_python-bcc() {
pkgdesc="BPF Compiler Collection - Python 3 bindings"
makedepends=('cmake')
depends=('bcc' 'python')
+ conflicts=('python-bcc-git')
# the C lib s already built, force a quick python3 binding build
cd "${srcdir}/${pkgbase}-${pkgver}/build"
@@ -92,6 +94,7 @@ package_python2-bcc() {
pkgdesc="BPF Compiler Collection - Python 2 bindings"
makedepends=('cmake')
depends=('bcc' 'python2')
+ conflicts=('python2-bcc-git')
# the C lib s already built, force a quick python2 binding build
cd "${srcdir}/${pkgbase}-${pkgver}/build"