summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Krause2016-03-05 11:52:48 +0100
committerChristian Krause2016-03-05 11:52:48 +0100
commit1697c044fd17ecad05304595cd7101d55443e6f8 (patch)
tree43317d50f9ffc74a229e185f3a056af1dcb23159
parent295038a40f0e6bafafc7765250919f555557a74a (diff)
downloadaur-1697c044fd17ecad05304595cd7101d55443e6f8.tar.gz
bcftools-1.3-3
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ddf4e279875..1bbb79622c3d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,21 @@
# Generated by mksrcinfo v8
-# Sat Mar 5 10:39:13 UTC 2016
+# Sat Mar 5 10:52:13 UTC 2016
pkgbase = bcftools
pkgdesc = Reading/writing BCF2/VCF/gVCF files and calling/filtering/summarising SNP and short indel sequence variants
pkgver = 1.3
- pkgrel = 2
+ pkgrel = 3
url = http://samtools.github.io/bcftools/
arch = i686
arch = x86_64
license = GPL
+ depends = gsl
depends = htslib
depends = perl
source = https://github.com/samtools/bcftools/releases/download/1.3/bcftools-1.3.tar.bz2
+ source = https://github.com/pd3/bcftools/commit/946b7eea6d699731f72124d87b3176e0ced4d25a.patch
source = makefile-system-htslib.patch
md5sums = 17f1f7d9e4a03d64a114b43ca896899f
+ md5sums = dd48ce1ac8ef91ea409f8f235574de2e
md5sums = e5145d175dcd242634baf42749b838f0
pkgname = bcftools
diff --git a/PKGBUILD b/PKGBUILD
index 24fec0d000e5..a7c088092ef2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,17 @@
pkgname=bcftools
pkgver=1.3
-pkgrel=2
+pkgrel=3
pkgdesc="Reading/writing BCF2/VCF/gVCF files and calling/filtering/summarising SNP and short indel sequence variants"
arch=('i686' 'x86_64')
url="http://samtools.github.io/bcftools/"
license=('GPL')
-depends=('htslib' 'perl') # 'gsl'
+depends=('gsl' 'htslib' 'perl')
source=(https://github.com/samtools/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.bz2
+ https://github.com/pd3/bcftools/commit/946b7eea6d699731f72124d87b3176e0ced4d25a.patch
makefile-system-htslib.patch)
md5sums=('17f1f7d9e4a03d64a114b43ca896899f'
+ 'dd48ce1ac8ef91ea409f8f235574de2e'
'e5145d175dcd242634baf42749b838f0')
prepare() {
@@ -21,22 +23,25 @@ prepare() {
# patch Makefile to make it work with a system-provided htslib
patch -i $srcdir/makefile-system-htslib.patch
+
+ # patch gsl >= 2 problem
+ patch -i $srcdir/946b7eea6d699731f72124d87b3176e0ced4d25a.patch
}
build() {
cd $srcdir/$pkgname-$pkgver
- make prefix=/usr plugindir=/usr/lib/$pkgname # USE_GPL=1
+ make prefix=/usr plugindir=/usr/lib/$pkgname USE_GPL=1
}
check() {
cd $srcdir/$pkgname-$pkgver
- make prefix=/usr plugindir=/usr/lib/$pkgname # USE_GPL=1 test
+ make prefix=/usr plugindir=/usr/lib/$pkgname USE_GPL=1 test
}
package() {
cd $srcdir/$pkgname-$pkgver
- make prefix=/usr plugindir=/usr/lib/$pkgname DESTDIR=$pkgdir install # USE_GPL=1
+ make prefix=/usr plugindir=/usr/lib/$pkgname USE_GPL=1 DESTDIR=$pkgdir install
}