summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2018-01-22 22:37:56 -0500
committerGuillaume Horel2018-01-22 22:39:38 -0500
commit3e624917a6d497ac2f18ccbbd1640b2928576862 (patch)
tree4f8d0fdfb636852b413b8d6ff2a3d0dce206e40b
downloadaur-3e624917a6d497ac2f18ccbbd1640b2928576862.tar.gz
initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8942256c948d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = bcmatroska2-git
+ pkgdesc = A C library for working with matroska files
+ pkgver = 0.23.r2.g85e73f9
+ pkgrel = 1
+ url = http://www.linphone.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ source = git://git.linphone.org/libmatroska-c.git
+ sha256sums = SKIP
+
+pkgname = bcmatroska2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02ddf5d9470c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id$
+# Contributor: Guillaume Horel <guillaume.horel@gmail.com>
+
+pkgname=bcmatroska2-git
+_pkgname=libmatroska-c
+pkgver=0.23.r2.g85e73f9
+pkgrel=1
+pkgdesc="A C library for working with matroska files"
+arch=('i686' 'x86_64')
+url="http://www.linphone.org/"
+license=('GPL')
+makedepends=('cmake')
+source=("git://git.linphone.org/$_pkgname.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_LIBDIR="/usr/lib" \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DENABLE_STATIC=NO \
+ ../$_pkgname
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}" install
+}