summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoribrokemypie2022-06-13 14:50:05 +1000
committeribrokemypie2022-06-13 14:50:05 +1000
commit1063f2908231d397470675bb6d15d86399f67118 (patch)
tree0be900d11197aed3d4e653877303d80b1389d77c
parent97e85d91c4f7bec405c5c677f90ef31bc36ec3d4 (diff)
downloadaur-1063f2908231d397470675bb6d15d86399f67118.tar.gz
build with maturin
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD24
2 files changed, 23 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e981ab79650..39027babfea6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bcml-git
pkgdesc = Breath of the Wild Cross-Platform Mod Loader: A mod merger and manager for BOTW
- pkgver = r1096.4068f61
+ pkgver = r1178.95cab60
pkgrel = 1
url = https://github.com/NiceneNerd/BCML
arch = x86_64
@@ -10,10 +10,11 @@ pkgbase = bcml-git
makedepends = nodejs>=14.0.0
makedepends = mkdocs
makedepends = mkdocs-material
- makedepends = python-wheel
- makedepends = python-build
makedepends = python-installer
makedepends = gendesk
+ makedepends = cargo-nightly
+ makedepends = maturin
+ makedepends = cmake
depends = python>=3.7
depends = p7zip
depends = python-numpy
diff --git a/PKGBUILD b/PKGBUILD
index 94d76485e79f..392dfff228f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: ibrokemypie <ibrokemypie@bastardi.net>
pkgname=bcml-git
_name=BCML
-pkgver=r1096.4068f61
+pkgver=r1178.95cab60
pkgrel=1
pkgdesc="Breath of the Wild Cross-Platform Mod Loader: A mod merger and manager for BOTW"
arch=('x86_64')
@@ -25,7 +25,18 @@ depends=(
'python-rstb'
'python-xxhash'
)
-makedepends=('git' 'npm' 'nodejs>=14.0.0' 'mkdocs' 'mkdocs-material' 'python-wheel' 'python-build' 'python-installer' 'gendesk')
+makedepends=(
+ 'git'
+ 'npm'
+ 'nodejs>=14.0.0'
+ 'mkdocs'
+ 'mkdocs-material'
+ 'python-installer'
+ 'gendesk'
+ 'cargo-nightly'
+ 'maturin'
+ 'cmake'
+)
optdepends=('cemu')
source=('git+https://github.com/NiceneNerd/BCML' "${_name}.png::https://i.imgur.com/OiqKPx0.png")
sha256sums=('SKIP'
@@ -49,14 +60,17 @@ build() {
npm run build
cd "${srcdir}/${_name}"
- mkdocs build -d bcml/assets/help
+ mkdocs build -d ./bcml/assets/help
- python -m build --wheel --no-isolation
+ export RUSTUP_TOOLCHAIN=nightly
+ export CARGO_TARGET_DIR=target
+
+ maturin build --release
}
package() {
cd "${srcdir}/${_name}"
- python -m installer --destdir="$pkgdir" dist/*.whl
+ python -m installer --destdir="$pkgdir" target/wheels/*.whl
install -Dm644 "${srcdir}/${_name}.desktop" "$pkgdir/usr/share/applications/${_name}.desktop"
install -Dm644 "${srcdir}/${_name}.png" "$pkgdir/usr/share/pixmaps/${_name}.png"
}