summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel YC Lin2015-06-13 11:39:20 +0800
committerDaniel YC Lin2015-06-13 11:39:20 +0800
commit1b34f1264c122981d2f014ce6a3e59aa6145ad32 (patch)
tree34d535c94f655b07cc34d4dcb91f4041eefc4e5f
downloadaur-1b34f1264c122981d2f014ce6a3e59aa6145ad32.tar.gz
merge to aur4
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD27
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20497f35a633
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = bcpp
+ pkgdesc = utility for indents C/C++ source programs
+ pkgver = 20131209
+ pkgrel = 1
+ url = http://dickey.his.com/bcpp/bcpp.html
+ arch = i686
+ arch = x86_64
+ arch = sh4
+ license = custom
+ makedepends = gcc
+ depends = gcc-libs
+ depends = bash
+ source = http://invisible-island.net/datafiles/release/bcpp.tar.gz
+ md5sums = 36d8902e611c7e6c74a40b4ee44e3925
+
+pkgname = bcpp
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05e7a6298f95
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+## Ignore everything
+*.zip
+*.xz
+*.gz
+*.bz2
+*.7z
+*/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d219c44e45c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Contributor: Daniel YC Lin <dlin (at) gmail.com>
+# Maintainer: Daniel YC Lin <dlin (at) gmail.com>
+pkgname=bcpp
+pkgver=20131209
+pkgrel=1
+pkgdesc="utility for indents C/C++ source programs"
+arch=('i686' 'x86_64' sh4)
+url="http://dickey.his.com/bcpp/bcpp.html"
+license=("custom")
+makedepends=(gcc)
+depends=(gcc-libs bash)
+source=(http://invisible-island.net/datafiles/release/bcpp.tar.gz)
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr --mandir=/usr/share/man || return 1
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ cp code/bcpp.cfg "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/licenses/bcpp"
+ install -m644 COPYING "$pkgdir/usr/share/licenses/bcpp/"
+}
+md5sums=('36d8902e611c7e6c74a40b4ee44e3925')