summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Kharitonov2019-01-29 20:07:40 +0500
committerDmitry Kharitonov2019-01-29 20:07:40 +0500
commit1f9dfaec6fde0b032d94cd53fd41d88e5f2e0a01 (patch)
treeb515387fd0b48ac08b716448c3213dd01d7773f5
downloadaur-1f9dfaec6fde0b032d94cd53fd41d88e5f2e0a01.tar.gz
Initial import
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD79
2 files changed, 113 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d62bc9e109d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = bcrawl
+ pkgdesc = Continuation of X-Crawl fork of Dungeon Crawl Stone Soup roguelike with new content
+ pkgver = 1.10.1
+ pkgrel = 1
+ url = https://github.com/b-crawl/bcrawl
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = BSD
+ license = MIT
+ license = ZLIB
+ license = APACHE
+ license = custom:CC0
+ license = custom
+ makedepends = bison
+ makedepends = flex
+ makedepends = gendesk
+ makedepends = mesa
+ depends = lua51
+ depends = ncurses
+ depends = sdl2_image
+ depends = sqlite
+ depends = glu
+ depends = freetype2
+ depends = ttf-dejavu
+ optdepends = advancecomp: for recompressing the tilesheets
+ optdepends = pngcrush: for recompressing the tilesheets
+ conflicts = crawl
+ conflicts = stone-soup-tile
+ source = https://github.com/b-crawl/bcrawl/archive/bcrawl-1.10.1.tar.gz
+ sha256sums = 298764cba90effb21c82e8ff1f5aa58beeee704f3f188888f8d34627091fcd5f
+
+pkgname = bcrawl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27d382b9b30f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,79 @@
+# Maintainer: Dmitry Kharitonov <darksab0r@gmail.com>
+
+pkgname=bcrawl
+pkgver=1.10.1
+pkgrel=1
+pkgdesc='Continuation of X-Crawl fork of Dungeon Crawl Stone Soup roguelike with new content'
+arch=('i686' 'x86_64')
+url='https://github.com/b-crawl/bcrawl'
+depends=('lua51' 'ncurses' 'sdl2_image' 'sqlite' 'glu' 'freetype2' 'ttf-dejavu')
+makedepends=('bison' 'flex' 'gendesk' 'mesa')
+optdepends=('advancecomp: for recompressing the tilesheets'
+ 'pngcrush: for recompressing the tilesheets')
+conflicts=('crawl' 'stone-soup-tile')
+license=('GPL' 'BSD' 'MIT' 'ZLIB' 'APACHE' 'custom:CC0' 'custom')
+source=("https://github.com/b-crawl/bcrawl/archive/bcrawl-${pkgver}.tar.gz")
+sha256sums=('298764cba90effb21c82e8ff1f5aa58beeee704f3f188888f8d34627091fcd5f')
+
+# used by gendesk to create .desktop file
+_exec=('bcrawl-tiles')
+_name=('Dungeon Crawl Stone Soup (bcrawl fork)')
+
+package() {
+ cd "$srcdir"
+ gendesk -f -n --pkgname "$pkgname" --pkgdesc "$pkgdesc" \
+ --exec 'bcrawl-tiles' --name 'Dungeon Crawl Stone Soup (bcrawl fork)' PKGBUILD
+
+ cd "bcrawl-bcrawl-${pkgver}/crawl-ref/source"
+
+ # 0.16.0 weirdness
+ sed -i 's|SDL_main.h|SDL2/&|' main.cc
+
+ # git tarball weirdness
+ echo "$pkgver" > util/release_ver
+
+ # adjust makefile to use /usr/bin, owner root:root,
+ # disable setgid on executable
+
+ sed -i 's|bin_prefix := bin|bin_prefix := usr/bin|' Makefile
+ sed -i 's/INSTALL_UGRP := games:games/INSTALL_UGRP := root:root/' Makefile
+ sed -i 's|MCHMOD := 2755|MCHMOD := 755|' Makefile
+
+ # first build and install tiles version
+
+ make GAME=bcrawl \
+ DESTDIR="${pkgdir}" \
+ DATADIR="/usr/share/${pkgname}/data" \
+ SAVEDIR="~/.bcrawl" \
+ USE_UNICODE=y \
+ TILES=y \
+ install
+
+ # rename tiles executable to avoid clashing with console crawl
+
+ mv "${pkgdir}/usr/bin/bcrawl" "${pkgdir}/usr/bin/bcrawl-tiles"
+
+ # then build and install console version
+
+ make GAME=bcrawl \
+ DESTDIR="${pkgdir}" \
+ DATADIR="/usr/share/${pkgname}/data" \
+ SAVEDIR="~/.bcrawl" \
+ USE_UNICODE=y \
+ install
+
+ # install crawl license
+
+ install -D -m644 ../../LICENSE \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 ../docs/license/* \
+ "${pkgdir}/usr/share/licenses/${pkgname}"
+
+ # install icon and .desktop file
+
+ install -D -m644 dat/tiles/stone_soup_icon-32x32.png \
+ "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -D -m644 "${srcdir}/${pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+}