summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Kharitonov2019-01-29 20:29:15 +0500
committerDmitry Kharitonov2019-01-29 20:29:15 +0500
commit69c50188007794f860959d09261f1cc7cff27857 (patch)
tree487c25d8f03f4272b1e45cde2d46377a4e956ccd
downloadaur-69c50188007794f860959d09261f1cc7cff27857.tar.gz
Initial commit
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD86
2 files changed, 123 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7590e88497c6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+pkgbase = bcrawl-git
+ pkgdesc = Continuation of X-Crawl fork of Dungeon Crawl Stone Soup roguelike with new content (Git version)
+ pkgver = 1.10.1
+ pkgrel = 1
+ url = https://github.com/b-crawl/bcrawl
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = BSD
+ license = MIT
+ license = ZLIB
+ license = APACHE
+ license = custom:CC0
+ license = custom
+ makedepends = git
+ makedepends = bison
+ makedepends = flex
+ makedepends = gendesk
+ makedepends = mesa
+ depends = lua51
+ depends = ncurses
+ depends = sdl2_image
+ depends = sqlite
+ depends = glu
+ depends = freetype2
+ depends = ttf-dejavu
+ optdepends = advancecomp: for recompressing the tilesheets
+ optdepends = pngcrush: for recompressing the tilesheets
+ provides = bcrawl
+ conflicts = crawl
+ conflicts = stone-soup-tile
+ conflicts = bcrawl
+ source = git+https://github.com/b-crawl/bcrawl.git
+ sha256sums = 74481c2694d0ce61b3b196130a85fd681160783418fd6bca71270f105a164b33
+
+pkgname = bcrawl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..717f81688d55
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,86 @@
+# Maintainer: Dmitry Kharitonov <darksab0r@gmail.com>
+
+pkgname=bcrawl-git
+_pkgname=bcrawl
+pkgver=0.22.a0.2449.g78f4bf4443
+pkgrel=1
+pkgdesc='Continuation of X-Crawl fork of Dungeon Crawl Stone Soup roguelike with new content (Git version)'
+arch=('i686' 'x86_64')
+url='https://github.com/b-crawl/bcrawl'
+depends=('lua51' 'ncurses' 'sdl2_image' 'sqlite' 'glu' 'freetype2' 'ttf-dejavu')
+makedepends=('git' 'bison' 'flex' 'gendesk' 'mesa')
+optdepends=('advancecomp: for recompressing the tilesheets'
+ 'pngcrush: for recompressing the tilesheets')
+conflicts=('crawl' 'stone-soup-tile' 'bcrawl')
+provides=('bcrawl')
+license=('GPL' 'BSD' 'MIT' 'ZLIB' 'APACHE' 'custom:CC0' 'custom')
+source=("git+https://github.com/b-crawl/bcrawl.git")
+sha256sums=('SKIP')
+
+# used by gendesk to create .desktop file
+_exec=('bcrawl-tiles')
+_name=('Dungeon Crawl Stone Soup (bcrawl fork)')
+
+pkgver() {
+ cd "$srcdir"/bcrawl
+ git describe | sed 's#-#.#g'
+}
+
+package() {
+ cd "$srcdir"
+ gendesk -f -n --pkgname "$_pkgname" --pkgdesc "$pkgdesc" \
+ --exec 'bcrawl-tiles' --name 'Dungeon Crawl Stone Soup (bcrawl fork)' PKGBUILD
+
+ cd "$srcdir/bcrawl/crawl-ref/source"
+
+ # 0.16.0 weirdness
+ sed -i 's|SDL_main.h|SDL2/&|' main.cc
+
+ # git tarball weirdness
+ echo "$pkgver" > util/release_ver
+
+ # adjust makefile to use /usr/bin, owner root:root,
+ # disable setgid on executable
+
+ sed -i 's|bin_prefix := bin|bin_prefix := usr/bin|' Makefile
+ sed -i 's/INSTALL_UGRP := games:games/INSTALL_UGRP := root:root/' Makefile
+ sed -i 's|MCHMOD := 2755|MCHMOD := 755|' Makefile
+
+ # first build and install tiles version
+
+ make GAME=bcrawl \
+ DESTDIR="${pkgdir}" \
+ DATADIR="/usr/share/${_pkgname}/data" \
+ SAVEDIR="~/.bcrawl" \
+ USE_UNICODE=y \
+ TILES=y \
+ install
+
+ # rename tiles executable to avoid clashing with console crawl
+
+ mv "${pkgdir}/usr/bin/bcrawl" "${pkgdir}/usr/bin/bcrawl-tiles"
+
+ # then build and install console version
+
+ make GAME=bcrawl \
+ DESTDIR="${pkgdir}" \
+ DATADIR="/usr/share/${_pkgname}/data" \
+ SAVEDIR="~/.bcrawl" \
+ USE_UNICODE=y \
+ install
+
+ # install crawl license
+
+ install -D -m644 ../../LICENSE \
+ "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -D -m644 ../docs/license/* \
+ "${pkgdir}/usr/share/licenses/${_pkgname}"
+
+ # install icon and .desktop file
+
+ install -D -m644 dat/tiles/stone_soup_icon-32x32.png \
+ "${pkgdir}/usr/share/pixmaps/${_pkgname}.png"
+ install -D -m644 "${srcdir}/${_pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+
+}