summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2019-11-03 21:19:48 -0500
committerGuillaume Horel2019-11-03 21:19:48 -0500
commit0ff08cf192794fd61dcae95eb00efe96462de4a7 (patch)
tree2801800a363c0f58b16f4539c878e8b5c61bde1e
parent1ef2f627bcf87b02707bb9144accdb773674c5be (diff)
downloadaur-0ff08cf192794fd61dcae95eb00efe96462de4a7.tar.gz
update dependencies
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19cbd15da321..0c02b078cdea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = bctoolbox-git
pkgdesc = Utilities library for Belledonne Communications software
- pkgver = 0.6.0.r150.g94b50fe
+ pkgver = 0.6.0.r170.g25f4a51
pkgrel = 1
url = http://www.linphone.org/
arch = x86_64
license = GPL
makedepends = cmake
makedepends = git
+ depends = bcunit-git
depends = libdecaf
depends = mbedtls
provides = bctoolbox
diff --git a/PKGBUILD b/PKGBUILD
index 41c14bc491bb..5722ece0a180 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=bctoolbox-git
_pkgname=bctoolbox
-pkgver=0.6.0.r150.g94b50fe
+pkgver=0.6.0.r170.g25f4a51
pkgrel=1
pkgdesc="Utilities library for Belledonne Communications software"
arch=('x86_64')
@@ -10,7 +10,7 @@ url="http://www.linphone.org/"
license=('GPL')
conflicts=('bctoolbox')
provides=('bctoolbox')
-depends=('libdecaf' 'mbedtls')
+depends=('bcunit-git' 'libdecaf' 'mbedtls')
makedepends=('cmake' 'git')
source=("git+https://github.com/BelledonneCommunications/$_pkgname.git")
sha256sums=('SKIP')
@@ -25,8 +25,10 @@ build() {
cd build
cmake -DENABLE_TESTS_COMPONENT=NO \
-DCMAKE_INSTALL_LIBDIR="/usr/lib" \
- -DCMAKE_INSTALL_PREFIX="/usr" "../$_pkgname" \
- -DENABLE_STATIC="NO"
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DENABLE_STATIC="NO" \
+ -DENABLE_TESTS="YES" \
+ -DENABLE_TESTS_COMPONENT="YES" ../"${_pkgname}"
make
}