summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2020-12-19 16:25:40 -0500
committerGuillaume Horel2020-12-19 16:25:40 -0500
commit8f8f4825c28f1be738c2095f34cb60e0456f19f6 (patch)
tree423ad69e54ca457dae76ee54021c0d4b50799863
parentef3933b120d1fe7639bd2f90bc7c6535631899e3 (diff)
downloadaur-8f8f4825c28f1be738c2095f34cb60e0456f19f6.tar.gz
cmake cleanup
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD20
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02d7f1d46504..2266ebb4e3d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bctoolbox-git
pkgdesc = Utilities library for Belledonne Communications software
- pkgver = 4.5.0.alpha.r46.gb007955
+ pkgver = 4.5.0.alpha.r54.gab40b02
pkgrel = 1
url = http://www.linphone.org/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index d431ebf1ccba..ef2293f665b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=bctoolbox-git
_pkgname=bctoolbox
-pkgver=4.5.0.alpha.r46.gb007955
+pkgver=4.5.0.alpha.r54.gab40b02
pkgrel=1
pkgdesc="Utilities library for Belledonne Communications software"
arch=('x86_64')
@@ -21,17 +21,15 @@ pkgver() {
}
build() {
- mkdir -p build
- cd build
- cmake -DENABLE_TESTS_COMPONENT=NO \
- -DCMAKE_INSTALL_PREFIX="/usr" \
- -DENABLE_STATIC="NO" \
- -DENABLE_TESTS="YES" \
- -DENABLE_TESTS_COMPONENT="YES" ../"${_pkgname}"
- make
+ cmake -B build "${_pkgname}" \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DENABLE_STATIC="NO" \
+ -DENABLE_TESTS="YES" \
+ -DENABLE_TESTS_COMPONENT="YES" \
+ -Wno-dev
+ make -C build
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}" install
+ make DESTDIR="${pkgdir}" -C build install
}