summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2018-05-11 20:04:54 -0400
committerGuillaume Horel2018-05-11 20:04:54 -0400
commitcef88153f54c70830b42440dba1b07583401cb23 (patch)
tree510e6544d86310ac67fc5b18835b933e1db2836c
parente3856de3ff441e21f57e943cd537f7f2ac9efb86 (diff)
downloadaur-cef88153f54c70830b42440dba1b07583401cb23.tar.gz
version bump
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 003816ea0c07..b641cc4f3a3b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bctoolbox-git
pkgdesc = Utilities library for Belledonne Communications software
- pkgver = 0.6.0.r84.g7df8b5c
+ pkgver = 0.6.0.r87.g934484a
pkgrel = 1
url = http://www.linphone.org/
arch = i686
@@ -13,7 +13,9 @@ pkgbase = bctoolbox-git
provides = bctoolbox
conflicts = bctoolbox
source = git://github.com/BelledonneCommunications/bctoolbox.git
+ source = stringop-truncation.patch::https://patch-diff.githubusercontent.com/raw/BelledonneCommunications/bctoolbox/pull/5.patch
sha256sums = SKIP
+ sha256sums = 614c919c46efb7e70a3dba3991741db2816784673dc6f35d26b9828163b1af07
pkgname = bctoolbox-git
diff --git a/PKGBUILD b/PKGBUILD
index 114fa0795bd4..c4ce91fb2e06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=bctoolbox-git
_pkgname=bctoolbox
-pkgver=0.6.0.r84.g7df8b5c
+pkgver=0.6.0.r87.g934484a
pkgrel=1
pkgdesc="Utilities library for Belledonne Communications software"
arch=('i686' 'x86_64')
@@ -13,14 +13,21 @@ conflicts=('bctoolbox')
provides=('bctoolbox')
depends=('libdecaf' 'mbedtls')
makedepends=('cmake' 'git')
-source=("git://github.com/BelledonneCommunications/$_pkgname.git")
-sha256sums=('SKIP')
+source=("git://github.com/BelledonneCommunications/$_pkgname.git"
+ "stringop-truncation.patch::https://patch-diff.githubusercontent.com/raw/BelledonneCommunications/bctoolbox/pull/5.patch")
+sha256sums=('SKIP'
+ '614c919c46efb7e70a3dba3991741db2816784673dc6f35d26b9828163b1af07')
pkgver() {
cd "${srcdir}/${_pkgname}"
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "${_pkgname}"
+ patch -p1 < ../stringop-truncation.patch
+}
+
build() {
mkdir -p build
cd build