summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2018-05-23 20:39:21 -0400
committerGuillaume Horel2018-05-23 20:39:21 -0400
commitd517e394fb1c5bda5f515f59ccfec1235ba47454 (patch)
treec817fc3ff1531d38a0321bbef8043351aafe181f
parentcef88153f54c70830b42440dba1b07583401cb23 (diff)
downloadaur-d517e394fb1c5bda5f515f59ccfec1235ba47454.tar.gz
remove the patch which is now upstream
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD16
2 files changed, 5 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b641cc4f3a3b..04441fadc0bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = bctoolbox-git
pkgdesc = Utilities library for Belledonne Communications software
- pkgver = 0.6.0.r87.g934484a
+ pkgver = 0.6.0.r92.g2425a22
pkgrel = 1
url = http://www.linphone.org/
- arch = i686
arch = x86_64
license = GPL
makedepends = cmake
@@ -13,9 +12,7 @@ pkgbase = bctoolbox-git
provides = bctoolbox
conflicts = bctoolbox
source = git://github.com/BelledonneCommunications/bctoolbox.git
- source = stringop-truncation.patch::https://patch-diff.githubusercontent.com/raw/BelledonneCommunications/bctoolbox/pull/5.patch
sha256sums = SKIP
- sha256sums = 614c919c46efb7e70a3dba3991741db2816784673dc6f35d26b9828163b1af07
pkgname = bctoolbox-git
diff --git a/PKGBUILD b/PKGBUILD
index c4ce91fb2e06..1d20ef7a85fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,25 @@
-# $Id$
# Contributor: Guillaume Horel <guillaume.horel@gmail.com>
pkgname=bctoolbox-git
_pkgname=bctoolbox
-pkgver=0.6.0.r87.g934484a
+pkgver=0.6.0.r92.g2425a22
pkgrel=1
pkgdesc="Utilities library for Belledonne Communications software"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://www.linphone.org/"
license=('GPL')
conflicts=('bctoolbox')
provides=('bctoolbox')
depends=('libdecaf' 'mbedtls')
makedepends=('cmake' 'git')
-source=("git://github.com/BelledonneCommunications/$_pkgname.git"
- "stringop-truncation.patch::https://patch-diff.githubusercontent.com/raw/BelledonneCommunications/bctoolbox/pull/5.patch")
-sha256sums=('SKIP'
- '614c919c46efb7e70a3dba3991741db2816784673dc6f35d26b9828163b1af07')
+source=("git://github.com/BelledonneCommunications/$_pkgname.git")
+sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${_pkgname}"
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd "${_pkgname}"
- patch -p1 < ../stringop-truncation.patch
-}
-
build() {
mkdir -p build
cd build