summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHugo Osvaldo Barrera2017-04-26 11:10:54 -0300
committerGitHub2017-04-26 11:10:54 -0300
commit347e66710a23ff0e7acfde92a507835ba682ea9c (patch)
tree3364826338a273724435355e07147792413fcab9
parent379237d307e813333cc89cb5657693170f17b34a (diff)
parentcdc20e028e01c2ab3246434c6ddb2b4dc65d6c0b (diff)
downloadaur-347e66710a23ff0e7acfde92a507835ba682ea9c.tar.gz
Merge pull request #1 from christophgysin/sensorid-fix
Sensorid fix
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50530bcc84e1..ea18417b1763 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Apr 25 15:36:14 UTC 2017
+# Wed Apr 26 05:31:11 UTC 2017
pkgbase = bcwc-pcie-dkms
pkgdesc = Reverse engineered Linux driver for the Broadcom 1570 PCIe webcam.
- pkgver = 0r231.0712f39
+ pkgver = 0r249.758fe01
pkgrel = 1
url = https://github.com/patjak/bcwc_pcie
install = bcwc-pcie-dkms.install
@@ -16,7 +16,7 @@ pkgbase = bcwc-pcie-dkms
provides = bcwc-pcie
conflicts = bcwc-pcie
conflicts = bcwc-pcie-git
- source = bcwc-pcie-dkms::git+https://github.com/patjak/bcwc_pcie.git
+ source = bcwc-pcie-dkms::git+https://github.com/patjak/bcwc_pcie.git#branch=mainline
source = bcwc-pcie.modprobe.conf
source = bcwc-pcie.modules-load.conf
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 565d4ee081eb..1ca3e81eed59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Hugo Osvaldo Barrera <hugo@barrera.io>
pkgname="bcwc-pcie-dkms"
-pkgver=0r231.0712f39
+pkgver=0r249.758fe01
pkgrel=1
pkgdesc="Reverse engineered Linux driver for the Broadcom 1570 PCIe webcam."
arch=('x86_64')
@@ -13,7 +13,7 @@ conflicts=("bcwc-pcie" "bcwc-pcie-git")
provides=("bcwc-pcie")
install="$pkgname.install"
-source=("$pkgname::git+https://github.com/patjak/bcwc_pcie.git"
+source=("$pkgname::git+https://github.com/patjak/bcwc_pcie.git#branch=mainline"
"bcwc-pcie.modprobe.conf"
"bcwc-pcie.modules-load.conf")
md5sums=('SKIP'
@@ -26,13 +26,13 @@ pkgver() {
}
package() {
- cd "$srcdir/"
+ cd $srcdir/$pkgname
- install -Dm 644 $pkgname/dkms.conf "${pkgdir}/usr/src/bcwc-pcie-${pkgver}/dkms.conf"
+ # add dkms config
+ git cherry-pick 76945312a9d2e786bebc9bb5711f5962365c5c20
+ git cherry-pick 4901c363e8688a46b83bfcbee92c1588dca6054c
- cd $srcdir/$pkgname
- rm -rf .git
- for FILE in $(find -type f); do
+ for FILE in dkms.conf Makefile *.[ch]; do
install -Dm 644 "$FILE" "$pkgdir/usr/src/${pkgname/-dkms/}-${pkgver}/$FILE"
done