summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Lima2015-11-01 16:42:21 -0200
committerDaniel Lima2015-11-01 16:42:21 -0200
commitd96410939002a5c26ccb8f7bd2a842b603045473 (patch)
tree9385316d6420741222dfea7d9e5c3744f4c33613
downloadaur-d96410939002a5c26ccb8f7bd2a842b603045473.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
-rw-r--r--argc-check.diff4
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6f2454a0df6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = bdf2psf
+ pkgdesc = Debian utility to convert BDF font files to PSF format.
+ pkgver = 1.134
+ pkgrel = 1
+ url = https://packages.debian.org/sid/bdf2psf
+ arch = any
+ license = GPL2+
+ depends = perl
+ source = ftp://ftp.debian.org/debian/pool/main/c/console-setup/bdf2psf_1.134_all.deb
+ md5sums = 1b6aa7e384133f872d814e6e7bd2529e
+
+pkgname = bdf2psf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5abdbdf2704c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+pkgname=bdf2psf
+pkgdesc='Debian utility to convert BDF font files to PSF format.'
+pkgver=1.134
+pkgrel=1
+arch=('any')
+license=('GPL2+')
+url='https://packages.debian.org/sid/bdf2psf'
+source=("ftp://ftp.debian.org/debian/pool/main/c/console-setup/bdf2psf_${pkgver}_all.deb")
+md5sums=('1b6aa7e384133f872d814e6e7bd2529e')
+depends=('perl')
+
+build() {
+ cd "$srcdir"
+ tar -xf data.tar.xz
+ patch "usr/bin/bdf2psf" "../argc-check.diff"
+}
+
+package() {
+ cd "$srcdir"
+ cp -r usr "$pkgdir"
+}
diff --git a/argc-check.diff b/argc-check.diff
new file mode 100644
index 000000000000..8342143fc248
--- /dev/null
+++ b/argc-check.diff
@@ -0,0 +1,4 @@
+43c43
+< if ($ARGV[0] eq "--help" || $ARGV[0] eq "-h") {
+---
+> if ($#ARGV < 0 || $ARGV[0] eq "--help" || $ARGV[0] eq "-h") {