summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFredrick Brennan2022-01-29 16:56:47 -0500
committerFredrick Brennan2022-01-29 16:58:36 -0500
commita75b789195e7913705a53ef0e01110bf76d74e34 (patch)
tree459ad7f89c0f603788b0adc68634c83d7290831f
downloadaur-a75b789195e7913705a53ef0e01110bf76d74e34.tar.gz
v2005-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD31
-rw-r--r--SOURCE.md26
-rw-r--r--bdf2psf.tar.zstdbin0 -> 7241 bytes
4 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6340309d6f66
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = bdf2psf-pre0.2
+ pkgdesc = Bitmap font conversion utility with a very long history (pre-2006 source)
+ pkgver = 2005
+ pkgrel = 1
+ arch = any
+ license = GPL2
+ depends = perl
+ provides = bdf2psf
+ conflicts = bdf2psf
+ source = bdf2psf.tar.zstd
+ sha512sums = b267abce37bcb23f9f78b79921ded8ea12e85cbb9b44d6e4b4fa0fba979ccea0bb9bba97cc405214f37938fdb1292feedb9fac6108413f2dc5f345563c47999a
+
+pkgname = bdf2psf-pre0.2
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..223a61bf836b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Fredrick Brennan <copypaste@kittens.ph>
+
+pkgname=bdf2psf-pre0.2
+pkgver=2005
+pkgrel=1
+pkgdesc='Bitmap font conversion utility with a very long history (pre-2006 source)'
+depends=('perl')
+provides=('bdf2psf')
+conflicts=('bdf2psf')
+arch=('any')
+license=('GPL2')
+source=('bdf2psf.tar.zstd')
+sha512sums=('b267abce37bcb23f9f78b79921ded8ea12e85cbb9b44d6e4b4fa0fba979ccea0bb9bba97cc405214f37938fdb1292feedb9fac6108413f2dc5f345563c47999a')
+
+build() {
+ set -x
+ cd $srcdir
+ which bat && bat no_argv.patch || cat no_argv.patch
+ patch < no_argv.patch
+ set +x
+}
+
+package() {
+ set -x
+ chmod oga+x $srcdir/bdf2psf
+ mkdir -p $pkgdir/usr/bin/
+ mkdir -p $pkgdir/usr/share/licenses/$pkgname/
+ install -t $pkgdir/usr/bin/ $srcdir/bdf2psf
+ install -t $pkgdir/usr/share/licenses/$pkgname/ $srcdir/SOURCE.md
+ set +x
+}
diff --git a/SOURCE.md b/SOURCE.md
new file mode 100644
index 000000000000..456f310304dc
--- /dev/null
+++ b/SOURCE.md
@@ -0,0 +1,26 @@
+File came from https://raw.githubusercontent.com/dankamongmen/sprezzos-world/master/packaging/console-setup/Fonts/bdf2psf
+
+Stated license, copied from file—
+
+```perl
+#!/usr/bin/perl
+
+# bdf2psf -- convert unicode BDF fonts to Linux console fonts
+# Copyright © 2005 Anton Zinoviev <anton@lml.bas.bg>
+# Contains code from the bdftopsf.pl utility (Terminus font suite)
+# Copyright © 2004 Dimitar Toshkov Zhekov
+
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# If you have not received a copy of the GNU General Public License
+# along with this program, write to the Free Software Foundation, Inc.,
+# 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+```
diff --git a/bdf2psf.tar.zstd b/bdf2psf.tar.zstd
new file mode 100644
index 000000000000..91d7fa12c6e5
--- /dev/null
+++ b/bdf2psf.tar.zstd
Binary files differ