summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrnndxb wxcy2015-06-10 20:07:04 -0400
committerrnndxb wxcy2015-06-10 20:07:04 -0400
commite99f3d9defbfb0ee9272abdad3fd6b0ba68a37a2 (patch)
tree1fcf8dd60a6ce394c8cd20826e60898cd1366024
downloadaur-e99f3d9defbfb0ee9272abdad3fd6b0ba68a37a2.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--010_ftbfs-gcc4.patch14
-rw-r--r--020_minus-sign.patch14
-rw-r--r--PKGBUILD39
4 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc02c4f47a32
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = bdfresize
+ pkgdesc = A command to scale fonts in Bitmap Distribution Format
+ pkgver = 1.5
+ pkgrel = 1
+ url = http://openlab.ring.gr.jp/efont
+ arch = i686
+ arch = x86_64
+ license = GPL
+ source = http://openlab.ring.gr.jp/efont/dist/tools/bdfresize/bdfresize-1.5.tar.gz
+ source = 010_ftbfs-gcc4.patch
+ source = 020_minus-sign.patch
+ sha256sums = 440cfc0620a0237e46352c14a0774caa3f3059759b0a20defefc94e8490897a6
+ sha256sums = b2bfe278b5719ce8b946e20372d4a8d4c6630eeb74c0212c1c454911676ecbd9
+ sha256sums = ee1032245a87e6821d83cfff5230585ba707f307263a56b20f0f3672686832c1
+
+pkgname = bdfresize
+
diff --git a/010_ftbfs-gcc4.patch b/010_ftbfs-gcc4.patch
new file mode 100644
index 000000000000..219593d84b4d
--- /dev/null
+++ b/010_ftbfs-gcc4.patch
@@ -0,0 +1,14 @@
+Description: Fix FTBFS with gcc 4.0
+Origin: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=258509#5
+Bug-Debian: http://bugs.debian.org/258509
+
+--- bdfresize-1.5/charresize.c 2000-12-12 20:18:14.000000000 +0900
++++ bdfresize-1.5-3.1/charresize.c 2008-05-11 23:01:11.000000000 +0900
+@@ -46,7 +46,6 @@
+ void
+ processChar(void)
+ {
+- char *malloc();
+ char *srcimage;
+ int *dstgray;
+
diff --git a/020_minus-sign.patch b/020_minus-sign.patch
new file mode 100644
index 000000000000..54d69a09bebd
--- /dev/null
+++ b/020_minus-sign.patch
@@ -0,0 +1,14 @@
+Description: The - sign escapes, changes in debian/1.5-4
+Author: Frank Lichtenheld <djpig@debian.org>
+
+--- bdfresize-1.5/bdfresize.1 2000-12-11 17:18:15.000000000 +0900
++++ bdfresize-1.5-4/bdfresize.1 2008-05-11 23:01:11.000000000 +0900
+@@ -2,7 +2,7 @@
+ .SH NAME
+ bdfresize \- Resize BDF Format Font
+ .SH SYNOPSIS
+-bdfresize [-v] [-b \fInumber\fP] [-[whf] \fIfactor\fP] [\fIbdf-file\fP]
++bdfresize [\-v] [\-b \fInumber\fP] [\-[whf] \fIfactor\fP] [\fIbdf-file\fP]
+ .SH DESCRIPTION
+ .I Bdfresize
+ is a command to magnify or reduce fonts which are described with
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02c9075d5719
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: ntwk <rnndxb@gmail.com>
+
+pkgname=bdfresize
+pkgver=1.5
+pkgrel=1
+epoch=
+pkgdesc="A command to scale fonts in Bitmap Distribution Format"
+arch=('i686' 'x86_64')
+url="http://openlab.ring.gr.jp/efont"
+license=('GPL')
+source=("$url/dist/tools/$pkgname/$pkgname-$pkgver.tar.gz"
+ "010_ftbfs-gcc4.patch"
+ "020_minus-sign.patch")
+sha256sums=('440cfc0620a0237e46352c14a0774caa3f3059759b0a20defefc94e8490897a6'
+ 'b2bfe278b5719ce8b946e20372d4a8d4c6630eeb74c0212c1c454911676ecbd9'
+ 'ee1032245a87e6821d83cfff5230585ba707f307263a56b20f0f3672686832c1')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -p1 -i "../010_ftbfs-gcc4.patch"
+ patch -p1 -i "../020_minus-sign.patch"
+ autoreconf -vfi
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}