summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJC Francois2018-01-03 16:01:33 +0100
committerJC Francois2018-01-03 16:01:33 +0100
commit2e0913d3094df1ec3a8e8318028d435ec01a02cf (patch)
treeb09a4e302843c4d87685bf2916808983900d6acc
downloadaur-2e0913d3094df1ec3a8e8318028d435ec01a02cf.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--LICENSE9
-rw-r--r--PKGBUILD31
-rw-r--r--beaker-browser.desktop12
-rwxr-xr-xbeaker-browser.sh23
-rw-r--r--beaker.pngbin0 -> 3606 bytes
6 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..57fc8d1add35
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = beaker-browser-bin
+ pkgdesc = Peer-to-peer browser with tools to create and host websites
+ pkgver = 0.7.10
+ pkgrel = 1
+ url = https://beakerbrowser.com/
+ arch = x86_64
+ license = Modified MIT License (MIT)
+ provides = beaker-browser
+ provides = beakerbrowser
+ options = !strip
+ source = https://github.com/beakerbrowser/beaker/releases/download/0.7.10/beaker-browser-0.7.10-x86_64.AppImage
+ source = beaker-browser.desktop
+ source = beaker-browser.sh
+ source = beaker.png
+ source = LICENSE
+ md5sums = fc52cd3de85b7410632be78c9d224565
+ md5sums = 9b63b4e9b329c43ccbf4c9fda09afbd0
+ md5sums = d7c3dc2c0215ca9bd00d726175869918
+ md5sums = 9cbb1795dc2934472f7c2b021294964d
+ md5sums = 3862c029863f42c81265a712f9c17c4c
+
+pkgname = beaker-browser-bin
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..e2f98ff7666e
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,9 @@
+Modified MIT License (MIT)
+
+Copyright (c) 2017 Paul Frazee
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d19d27895e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Your Name <jc.francois@gmail.com>
+pkgname=beaker-browser-bin
+pkgver=0.7.10
+pkgrel=1
+pkgdesc="Peer-to-peer browser with tools to create and host websites"
+arch=('x86_64')
+url="https://beakerbrowser.com/"
+license=('Modified MIT License (MIT)')
+provides=('beaker-browser' 'beakerbrowser')
+backup=()
+
+options=(!strip)
+source=("https://github.com/beakerbrowser/beaker/releases/download/${pkgver}/beaker-browser-${pkgver}-${arch}.AppImage"
+ "beaker-browser.desktop"
+ "beaker-browser.sh"
+ "beaker.png"
+ "LICENSE")
+noextract=()
+md5sums=('fc52cd3de85b7410632be78c9d224565'
+ '9b63b4e9b329c43ccbf4c9fda09afbd0'
+ 'd7c3dc2c0215ca9bd00d726175869918'
+ '9cbb1795dc2934472f7c2b021294964d'
+ '3862c029863f42c81265a712f9c17c4c')
+
+package() {
+ install -Dm644 ${srcdir}/beaker-browser.desktop ${pkgdir}/usr/share/applications/beaker-browser.desktop
+ install -Dm644 ${srcdir}/beaker.png ${pkgdir}/usr/share/icons/hicolor/48x48/apps/beaker.png
+ install -Dm444 ${srcdir}/LICENSE ${pkgdir}/usr/share/LICENSES/beaker-browser/LICENSE
+ install -Dm755 ${srcdir}/beaker-browser.sh ${pkgdir}/opt/beaker-browser/beaker-browser.sh
+ install -Dm755 ${srcdir}/beaker-browser-${pkgver}-${arch}.AppImage ${pkgdir}/opt/beaker-browser/beaker-browser.AppImage
+}
diff --git a/beaker-browser.desktop b/beaker-browser.desktop
new file mode 100644
index 000000000000..4de5e07f3141
--- /dev/null
+++ b/beaker-browser.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Name=beaker-browser
+Comment=Peer-to-peer browser with tools to create and host website
+GenericName=Beaker Browser
+Exec=/opt/beaker-browser/beaker-browser.sh
+Icon=beaker
+Type=Application
+StartupNotify=true
+Terminal=false
+Categories=Development;Network;WebBrowser;
+Keywords=web;browser;internet;p2p;
+MimeType=text/html;x-scheme-handler/http;x-scheme-handler/https;
diff --git a/beaker-browser.sh b/beaker-browser.sh
new file mode 100755
index 000000000000..f840dfdfe8e2
--- /dev/null
+++ b/beaker-browser.sh
@@ -0,0 +1,23 @@
+#!/bin/bash
+
+# Avoid that install dialog is shown when starting browser
+export APPIMAGE_SILENT_INSTALL=1
+
+# Launch AppImage application
+/opt/beaker-browser/beaker-browser.AppImage
+
+# Since launching the AppImage performs the installation silently
+# remove files that have been installed locally after run
+if [ -e ~/.local/share/applications/appimagekit-beaker-browser.desktop ];
+then
+ rm ~/.local/share/applications/appimagekit-beaker-browser.desktop;
+
+ prefix=~/.local/share/icons/hicolor/
+ resolutions=(16x16 24x24 32x32 48x48 64x64 96x96 128x128 256x256 512x512 1024x1024)
+ postfix=/apps/appimagekit-beaker-browser.png
+
+ for i in {0..9};
+ do
+ echo ${prefix}${resolutions[$i]}${postfix};
+ done
+fi
diff --git a/beaker.png b/beaker.png
new file mode 100644
index 000000000000..2c768403eb6e
--- /dev/null
+++ b/beaker.png
Binary files differ