summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmando Ibarra2017-10-22 00:22:45 -0600
committerArmando Ibarra2017-10-22 00:22:45 -0600
commit0eb132dcb46f8253069be67e418d70cc71a079ad (patch)
tree335d1fd8bf879fe5807fba5198d9292676f65ce3
parent80d5ea73a0f02f544a86a5ca215b8af295a6e25e (diff)
downloadaur-0eb132dcb46f8253069be67e418d70cc71a079ad.tar.gz
Fix version AUR Out-of-date Notification for beakerbrowser and version with git checkout and so /tmp/alpm_5zaeyq/.INSTALL: line 1: syntax error near unexpected token LINE 1 on beakerbrowser.install
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore22
-rw-r--r--Makefile21
-rw-r--r--PKGBUILD92
-rw-r--r--beakerbrowser.install33
5 files changed, 121 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff9614bfce13..dcaa5975f009 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,7 +2,7 @@ pkgbase = beakerbrowser
pkgdesc = Beaker is an experimental peer-to-peer Web browser. It adds new APIs for \ building hostless applications, while remaining compatible with the rest of the Web
pkgver = 0.7.5
pkgrel = 1
- url = https://beakerbrowser.com/
+ url = https://github.com/beakerbrowser/beaker
install = beakerbrowser.install
arch = x86_64
license = Modified MIT License (MIT)
@@ -15,12 +15,11 @@ pkgbase = beakerbrowser
depends = electron
depends = nodejs
depends = p7zip
+ depends = xdg-utils
optdepends = gksu: sudo-save support
- source = git+https://github.com/beakerbrowser/beaker.git
source = beakerbrowser
source = LICENSE
source = beakerbrowser.desktop
- sha256sums = SKIP
sha256sums = c81c515820bc7f402732861140905eb1ddf99cc8ac0fc6ea1f0249750ff36a21
sha256sums = 7a0ab6f0bfde635de0dea1a5e57e641de973544ba9a5fb8498c098563ad35783
sha256sums = 2a47f24244ad653dd52728c952c78bc39d343c9c7c697279205eab6711d9e070
diff --git a/.gitignore b/.gitignore
index 95223da051a7..303c28cd6aa9 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,4 +3,24 @@ pkg
src
#files
-*.pkg.tar.xz \ No newline at end of file
+*._*
+.DS_Store
+*.pkg.tar.gz
+*.pkg.tar.xz
+*.zip
+*.rar
+*.sig
+*.asc
+*.tar
+*.tar.*
+*.zip
+*.tgz
+*.log
+*.log.*
+*.log.[0-9]*
+*.sig
+
+# atom deb package
+*.deb
+
+beaker/
diff --git a/Makefile b/Makefile
index 9695677aabdf..4657730bd61b 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,7 @@
-prepare:
+run:
+ sudo -v
+
+prepare-pkg:
namcap PKGBUILD
build:
@@ -32,9 +35,23 @@ install_pkg:
#Offline installation of packages test
sudo pacman -U beakerbrowser-0.7.5-1-x86_64.pkg.tar.xz
+#msgcommit:
+# git commit -m ${ARGS}
+
clean:
sudo -v;
if [ -d "beaker" ]; then sudo rm -r beaker; fi
if [ -d "pkg" ]; then sudo rm -r pkg; fi
if [ -d "src" ]; then sudo rm -r src; fi
- if [ -f "beakerbrowser-0.7.5-1-x86_64.pkg.tar.xz" ]; then sudo rm beakerbrowser-0.7.5-1-x86_64.pkg.tar.xz; fi \ No newline at end of file
+ if [ -f "beakerbrowser-0.7.5-1-x86_64.pkg.tar.xz" ]; then sudo rm beakerbrowser-0.7.5-1-x86_64.pkg.tar.xz; fi
+
+help:
+ @echo "Makefile for Building packege to AUR by Arch linux operating System."
+ @echo "make ARGS='this is a first commit' msgcommit"
+ @echo "Usage: make [ all | clean | help | build | run] "
+ @echo ""
+ @echo
+
+all: run prepare-pkg build check prepare-push install_pkg
+
+.DEFAULT: all \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index cec4df2c9da0..f79ea272f77d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,80 +1,108 @@
# Maintainer: Paul Frazee pfrazee@gmail.com
# Contributor: flaketill <armandoibarra1 at gmail dot com>
# Upstream URL: https://github.com/beakerbrowser/beaker
+# Web site="https://beakerbrowser.com/"
+_pkgname=beaker
pkgname=beakerbrowser
pkgver=0.7.5
pkgrel=1
pkgdesc="Beaker is an experimental peer-to-peer Web browser. It adds new APIs for \ building hostless applications, while remaining compatible with the rest of the Web"
arch=('x86_64')
-url="https://beakerbrowser.com/"
-license=('Modified MIT License (MIT)')
-depends=('electron' 'nodejs' 'p7zip')
+url="https://github.com/beakerbrowser/beaker"
+license=('Modified MIT License (MIT)')
+depends=('electron' 'nodejs' 'p7zip' 'xdg-utils')
checkdepends=('npm')
makedepends=('libtool' 'm4' 'automake' 'make' 'git')
optdepends=('gksu: sudo-save support')
install=${pkgname}.install
-#source=('git+https://github.com/beakerbrowser/beaker/archive/${pkgver}.tar.gz' \
-
-source=('git+https://github.com/beakerbrowser/beaker.git' \
-"$pkgname" \
-"LICENSE" \
-"${pkgname}.desktop"
-)
+source=("$pkgname"
+ "LICENSE"
+ "${pkgname}.desktop")
-sha256sums=('SKIP'
+sha256sums=(
c81c515820bc7f402732861140905eb1ddf99cc8ac0fc6ea1f0249750ff36a21
7a0ab6f0bfde635de0dea1a5e57e641de973544ba9a5fb8498c098563ad35783
2a47f24244ad653dd52728c952c78bc39d343c9c7c697279205eab6711d9e070
)
+msg_blue()
+{
+ printf "${BLUE}==>${ALL_OFF}${BOLD}·$1${ALL_OFF}\n"
+}
+
prepare() {
+
+ msg_blue "Connecting to git server..."
+ msg_blue "Please wait ..."
+
+ if [[ -d "$srcdir/$_pkgname" ]]; then
+ (cd "$_pkgname" && git pull origin master) || return 1
+ msg_blue "Repository updated"
+ else
+ git clone "$url.git" || return 1
+ msg "Repository cloned"
+ ls
+ sleep 2
+ pwd
+ sleep 2
+
+ fi
- cd "${srcdir}"
- cd beaker
}
build() {
-
- cd "${srcdir}/beaker"
- npm install
- npm run rebuild #see https://github.com/electron/electron/issues/5851
+
+ if [[ -d "$srcdir/$_pkgname" ]]; then
+ cd "${srcdir}/$_pkgname"
+ msg_blue "Checkout to version $pkgver"
+ git checkout $pkgver 2>/dev/null || return 1
+ msg_blue "Git status .."
+ git status
+ msg_blue "Using version $pkgver..."
+ npm install
+ npm run rebuild || return 1 #see https://github.com/electron/electron/issues/5851
+ fi
}
check() {
+ if [[ -d "$srcdir/$_pkgname" ]]; then
- cd "${srcdir}/beaker"
+ cd "${srcdir}/$_pkgname"
- if [ -d "node_modules" ]; then
- echo "OK node modules"
- fi
+ if [ -d "node_modules" ]; then
+ echo "OK node modules"
+ fi
- cd "${srcdir}"
+ cd "${srcdir}"
- if [ -f "${pkgname}" ]; then
- echo "OK bin file"
- fi
+ if [ -f "${pkgname}" ]; then
+ echo "OK bin file"
+ fi
- if [ -f "${pkgname}.desktop" ]; then
- echo "OK launcher"
- fi
+ if [ -f "${pkgname}.desktop" ]; then
+ echo "OK launcher"
+ fi
+
+ if [ -f "LICENSE" ]; then
+ echo "OK launcher"
+ fi
- if [ -f "LICENSE" ]; then
- echo "OK launcher"
+ #return 1
fi
}
package() {
- cd "${srcdir}/beaker"
+ cd "${srcdir}/$_pkgname"
#Copy icons for Desktop Integration
#install -Dm644 build/icons/48x48.png \
- #"$pkgdir/usr/share/icons/hicolor/48x48/apps/beaker.png"
+ #"$pkgdir/usr/share/icons/hicolor/48x48/apps/beaker.png"
cd "${srcdir}"
diff --git a/beakerbrowser.install b/beakerbrowser.install
index a86626c8b0f4..b7d0d23bf7f9 100644
--- a/beakerbrowser.install
+++ b/beakerbrowser.install
@@ -1,28 +1,33 @@
-msg_blue()·{
- printf·"${BLUE}==>${ALL_OFF}${BOLD}·$1${ALL_OFF}\n"
+ALL_OFF="$(tput sgr0)"
+BOLD="$(tput bold)"
+BLUE="${BOLD}$(tput setaf 4)"
+YELLOW="${BOLD}$(tput setaf 3)"
+
+msg_blue()
+{
+ printf "${BLUE}==>${ALL_OFF}${BOLD}·$1${ALL_OFF}\n"
}
+
# Colored makepkg-like functions
-note() {
+note()
+{
printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
}
-ALL_OFF="$(tput·sgr0)"
-BOLD="$(tput·bold)"
-BLUE="${BOLD}$(tput·setaf·4)"
-YELLOW="${BOLD}$(tput·setaf·3)"
-
-post_install() {
+post_install()
+{
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
- update-desktop-database -q
-
- note "npm run rebuild #see https://github.com/electron/electron/issues/5851"
+ update-desktop-database -q
+ note "npm run rebuild #see https://github.com/electron/electron/issues/5851"
}
-post_upgrade() {
+post_upgrade()
+{
post_install
}
-post_remove() {
+post_remove()
+{
post_install
} \ No newline at end of file