summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorflaketill2017-09-28 01:30:12 -0600
committerflaketill2017-09-28 01:30:12 -0600
commit81a7890d7a37884c597e6b5e8f3c0e589f1a061b (patch)
tree505238a911d349fc1d8b434c18ec3a135a6202c9
downloadaur-81a7890d7a37884c597e6b5e8f3c0e589f1a061b.tar.gz
Initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--LICENSE9
-rw-r--r--Makefile28
-rw-r--r--PKGBUILD121
-rw-r--r--beakerbrowser58
-rw-r--r--beakerbrowser.desktop13
-rw-r--r--beakerbrowser.install28
7 files changed, 285 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..61b758eadf59
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = beakerbrowser
+ pkgdesc = Beaker is an experimental peer-to-peer Web browser. It adds new APIs for \ building hostless applications, while remaining compatible with the rest of the Web
+ pkgver = 0.7.5
+ pkgrel = 1
+ url = https://beakerbrowser.com/
+ install = beakerbrowser.install
+ arch = x86_64
+ license = Modified MIT License (MIT)
+ checkdepends = npm
+ makedepends = libtool
+ makedepends = m4
+ makedepends = automake
+ makedepends = make
+ makedepends = git
+ depends = electron
+ depends = nodejs
+ optdepends = gksu: sudo-save support
+ source = git+https://github.com/beakerbrowser/beaker.git
+ source = beakerbrowser
+ source = LICENSE
+ source = beakerbrowser.desktop
+ sha256sums = SKIP
+ sha256sums = c81c515820bc7f402732861140905eb1ddf99cc8ac0fc6ea1f0249750ff36a21
+ sha256sums = 7a0ab6f0bfde635de0dea1a5e57e641de973544ba9a5fb8498c098563ad35783
+ sha256sums = 2a47f24244ad653dd52728c952c78bc39d343c9c7c697279205eab6711d9e070
+
+pkgname = beakerbrowser
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..e2f98ff7666e
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,9 @@
+Modified MIT License (MIT)
+
+Copyright (c) 2017 Paul Frazee
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. \ No newline at end of file
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..25087b383d59
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,28 @@
+prepare:
+ namcap PKGBUILD
+
+build:
+ makepkg -csi
+
+rebuild:
+ if [ -f "beakerbrowser-0.7.5-1-x86_64.pkg.tar.xz" ]; then sudo rm beakerbrowser-0.7.5-1-x86_64.pkg.tar.xz; fi
+ makepkg
+
+check:
+ namcap beakerbrowser-0.7.5-1-x86_64.pkg.tar.xz
+
+checkpkg:
+ makepkg --repackage
+
+prepare-push:
+ makepkg --printsrcinfo > .SRCINFO
+
+uploadpkg:
+ git add PKGBUILD .SRCINFO beakerbrowser beakerbrowser.desktop beakerbrowser.install LICENSE Makefile
+
+clean:
+ sudo -v;
+ if [ -d "beaker" ]; then sudo rm -r beaker; fi
+ if [ -d "pkg" ]; then sudo rm -r pkg; fi
+ if [ -d "src" ]; then sudo rm -r src; fi
+ if [ -f "beakerbrowser-0.7.5-1-x86_64.pkg.tar.xz" ]; then sudo rm beakerbrowser-0.7.5-1-x86_64.pkg.tar.xz; fi \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ccc91fac66b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,121 @@
+# Maintainer: Paul Frazee pfrazee@gmail.com
+# Contributor: flaketill <armandoibarra1 at gmail dot com>
+# Upstream URL: https://github.com/beakerbrowser/beaker
+
+pkgname=beakerbrowser
+pkgver=0.7.5
+pkgrel=1
+pkgdesc="Beaker is an experimental peer-to-peer Web browser. It adds new APIs for \ building hostless applications, while remaining compatible with the rest of the Web"
+arch=('x86_64')
+url="https://beakerbrowser.com/"
+license=('Modified MIT License (MIT)')
+
+depends=('electron' 'nodejs')
+checkdepends=('npm')
+makedepends=('libtool' 'm4' 'automake' 'make' 'git')
+optdepends=('gksu: sudo-save support')
+
+install=${pkgname}.install
+
+#source=('git+https://github.com/beakerbrowser/beaker/archive/${pkgver}.tar.gz' \
+
+source=('git+https://github.com/beakerbrowser/beaker.git' \
+"$pkgname" \
+"LICENSE" \
+"${pkgname}.desktop"
+)
+
+sha256sums=('SKIP'
+c81c515820bc7f402732861140905eb1ddf99cc8ac0fc6ea1f0249750ff36a21
+7a0ab6f0bfde635de0dea1a5e57e641de973544ba9a5fb8498c098563ad35783
+2a47f24244ad653dd52728c952c78bc39d343c9c7c697279205eab6711d9e070
+)
+
+prepare() {
+
+ cd "${srcdir}"
+ cd beaker
+}
+
+build() {
+
+ cd "${srcdir}/beaker"
+ npm install
+ #npm run rebuild #see https://github.com/electron/electron/issues/5851
+}
+
+check() {
+
+ cd "${srcdir}/beaker"
+
+ if [ -d "node_modules" ]; then
+ echo "OK node modules"
+ fi
+
+ cd "${srcdir}"
+
+ if [ -f "${pkgname}" ]; then
+ echo "OK bin file"
+ fi
+
+ if [ -f "${pkgname}.desktop" ]; then
+ echo "OK launcher"
+ fi
+
+ if [ -f "LICENSE" ]; then
+ echo "OK launcher"
+ fi
+
+}
+
+package() {
+
+ cd "${srcdir}/beaker"
+
+ #Copy icons for Desktop Integration
+ install -Dm644 build/icons/48x48.png \
+ "$pkgdir/usr/share/icons/hicolor/48x48/apps/beaker.png"
+
+ cd "${srcdir}"
+
+ echo "------------------------------------------------"
+ pwd
+ echo "------------------------------------------------"
+
+ #create dirs
+
+ mkdir -p ${pkgdir}/opt
+ mkdir -p "${pkgdir}/opt/${pkgname}"
+
+ echo -e "\033[1;31m==> Please wait until that installation is complete, Building the package... \033[1;0m \033[1;1m$1\033[1;0m" >&2
+
+ #Copy source to /opt
+ #mv "${srcdir}/beaker" "${pkgdir}/opt/${pkgname}/"
+
+ #cp -rf "${srcdir}/beaker" "${pkgdir}/opt/${pkgname}"
+
+ #cp -R --preserve=mode "${srcdir}/beaker" "${pkgdir}/opt/${pkgname}"
+ #install -Dm755 "${srcdir}/beaker" "${pkgdir}/opt/${pkgname}"
+ #chmod a+rx ${pkgdir}/opt/${pkgname}
+
+ echo -e "\033[1;31m==> Copy binaries \033[1;0m \033[1;1m$1\033[1;0m" >&2
+
+ # Install Binaries/Launchers
+ install -Dm755 ${pkgname} "$pkgdir"/usr/bin/${pkgname}
+ #ln -s /opt/${pkgname} ${pkgdir}/usr/bin/${pkgname}
+
+ #copy launcher to desktop
+ install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ #copy License
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ echo -e "\033[1;31m==> FIX permissions \033[1;0m \033[1;1m$1\033[1;0m" >&2
+
+ # Fix wonky permissions
+ find "${pkgdir}/opt/${pkgname}" -type d -exec chmod 755 {} \;
+ find "${pkgdir}/opt/${pkgname}" -type f -exec chmod 644 {} \;
+ chmod 755 "${pkgdir}/opt/${pkgname}"
+
+ echo -e "\033[1;31m==> The package is completed .... \033[1;0m \033[1;1m$1\033[1;0m" >&2
+} \ No newline at end of file
diff --git a/beakerbrowser b/beakerbrowser
new file mode 100644
index 000000000000..15d297045306
--- /dev/null
+++ b/beakerbrowser
@@ -0,0 +1,58 @@
+#!/usr/bin/env sh
+# -*- coding: UTF-8 -*-
+# Copyright (C) 2017 Armando Ibarra
+#
+#----------------------------------------------------------------------
+#
+# Author: Ing. Armando Ibarra - armandoibarra1@gmail.com
+# Email: armandoibarra1@gmail.com
+# Date: 27/09/2017
+# Purpose:
+# Open easy the Beaker Browser app
+#
+#----------------------------------------------------------------------
+# NOTES:
+#----------------------------------------------------------------------
+
+# Test on Arch linux x64
+#----------------------------------------------------------------------
+
+###############################################################################
+
+# Licensed under the GNU GPL v3 - http://www.gnu.org/licenses/gpl-3.0.txt
+# - or any later version.
+
+# A Desktop launcher for Beaker Browser
+
+# @author: Ing. Armando Ibarra
+
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+###############################################################################
+
+#variables
+
+AUTHOR='Ing. Armando Ibarra <armandoibarra1@gmail.com>'
+BEAKER_PATH_SOURCE="/opt/beakerbrowser"
+BEAKER_BIN_PATH="/usr/bin/beakerbrowser"
+BEAKER_ELECTRON_PATH="electron --app=/opt/beakerbrowser"
+
+if [ ! -d "$BEAKER_PATH_SOURCE" ] ; then
+ echo "/opt/beakerbrowser no exist" || exit 1
+fi
+
+#exec /usr/bin/beakerbrowser $@
+cd $BEAKER_PATH_SOURCE; npm start;
+
+exit 0 \ No newline at end of file
diff --git a/beakerbrowser.desktop b/beakerbrowser.desktop
new file mode 100644
index 000000000000..c454c72545cc
--- /dev/null
+++ b/beakerbrowser.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Version=0.7.5
+Type=Application
+Name=beakerbrowser
+GenericName=An experimental peer-to-peer Web browser
+Comment=Build peer-to-peer Web applications
+Exec=beakerbrowser
+Terminal=true
+MimeType=text/plain;
+Icon=beaker
+Categories=Development;
+StartupNotify=beakerbrowser
+StartupWMClass=beakerbrowser \ No newline at end of file
diff --git a/beakerbrowser.install b/beakerbrowser.install
new file mode 100644
index 000000000000..a86626c8b0f4
--- /dev/null
+++ b/beakerbrowser.install
@@ -0,0 +1,28 @@
+msg_blue()·{
+ printf·"${BLUE}==>${ALL_OFF}${BOLD}·$1${ALL_OFF}\n"
+}
+
+# Colored makepkg-like functions
+note() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+
+ALL_OFF="$(tput·sgr0)"
+BOLD="$(tput·bold)"
+BLUE="${BOLD}$(tput·setaf·4)"
+YELLOW="${BOLD}$(tput·setaf·3)"
+
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+
+ note "npm run rebuild #see https://github.com/electron/electron/issues/5851"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+} \ No newline at end of file