summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2021-03-24 22:59:25 -0400
committerPatrick Northon2021-03-24 22:59:25 -0400
commite56ff7ab0872066ddb7e69885ab1b54d4cde6dcb (patch)
treebe93f8929cb57b3d9ae30b6554d5de6f053d2761
downloadaur-e56ff7ab0872066ddb7e69885ab1b54d4cde6dcb.tar.gz
Initial commit.
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD25
3 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..130f5a1c0c0a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = beakerlib
+ pkgdesc = BeakerLib is a shell-level integration testing library, providing convenience functions which simplify writing, running and analysis of integration and blackbox tests.
+ pkgver = 1.26
+ pkgrel = 1
+ url = https://github.com/beakerlib/beakerlib
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ source = https://github.com/beakerlib/beakerlib/archive/refs/tags/1.26.tar.gz
+ sha256sums = ca16f5791f5e1212e97ad710a79cb5b43710efb1989450ab806cbab49c8b50a6
+
+pkgname = beakerlib
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c978251a8157
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Patrick Northon <northon_patrick3@yahoo.ca>
+
+pkgname=beakerlib
+pkgver=1.26
+pkgrel=1
+pkgdesc="BeakerLib is a shell-level integration testing library, providing convenience functions which simplify writing, running and analysis of integration and blackbox tests."
+arch=('i686' 'x86_64')
+url="https://github.com/beakerlib/beakerlib"
+license=('GPL2')
+depends=()
+makedepends=()
+source=("https://github.com/beakerlib/beakerlib/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('ca16f5791f5e1212e97ad710a79cb5b43710efb1989450ab806cbab49c8b50a6')
+
+_srcdir="${pkgname}-${pkgver}"
+
+build() {
+ cd "${_srcdir}"
+ make
+}
+
+package() {
+ cd "${_srcdir}"
+ make DD="${pkgdir}" install
+}