summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason Wang2020-12-08 20:40:19 +0800
committerJason Wang2020-12-08 20:40:19 +0800
commitb0da81586f77bb9ee2ded7123fc0f30336c1f22d (patch)
tree8b365adbc6aaf37d08b818ba4136e8da52dcf9c6
downloadaur-b0da81586f77bb9ee2ded7123fc0f30336c1f22d.tar.gz
Create beam package
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD26
-rw-r--r--beam.service9
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72169b3800de
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = beam-bin
+ pkgdesc = Free desktop application that delivers fast, reliable and secure access to the open Internet. (Stable Channel, binary)
+ pkgver = 0.1.19
+ pkgrel = 1
+ url = https://github.com/xiaoshoudian/xiazai
+ arch = i686
+ arch = x86_64
+ license = Apache
+ depends = libappindicator-gtk3
+ provides = beam
+ options = !emptydirs
+ options = !strip
+ options = !docs
+ source = beam.service
+ sha256sums = ebfb9ed2fe3d0c495c8e3af3beba1f907f67b43e9354726c4912fb2176fef298
+ source_x86_64 = beam-bin-0.1.19-x86_64.deb::https://github.com/xiaoshoudian/xiazai/raw/main/beam-installer-64-bit.deb
+ sha256sums_x86_64 = d78fd7cd89373fe983daff9f881509fcbcbe94c37dea973c6dd75b09325b978e
+
+pkgname = beam-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe7698fef196
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Marcin (CTRL) Wieczorek <marcin@marcin.co>
+# Contributor: neo.shadowsocks<neo.shadowsocks AT gmx.com>
+# Contributor: Kars Wang <jaklsy g-mail>
+
+pkgname=beam-bin
+pkgver=0.1.19
+pkgrel=1
+pkgdesc='Free desktop application that delivers fast, reliable and secure access to the open Internet. (Stable Channel, binary)'
+arch=('i686' 'x86_64')
+url='https://github.com/xiaoshoudian/xiazai'
+license=('Apache')
+depends=('libappindicator-gtk3')
+options=('!emptydirs' '!strip' '!docs')
+provides=('beam')
+source=('beam.service')
+source_x86_64=("${pkgname}-${pkgver}-x86_64.deb::https://github.com/xiaoshoudian/xiazai/raw/main/beam-installer-64-bit.deb")
+sha256sums=('ebfb9ed2fe3d0c495c8e3af3beba1f907f67b43e9354726c4912fb2176fef298')
+sha256sums_x86_64=('d78fd7cd89373fe983daff9f881509fcbcbe94c37dea973c6dd75b09325b978e')
+
+package() {
+ msg2 'Extracting the data.tar.xz...'
+ bsdtar -xzf data.tar.gz -C "${pkgdir}/"
+
+ msg2 'Install systemd service file...'
+ install -Dm644 "${srcdir}/beam.service" "${pkgdir}/usr/lib/systemd/user/beam.service"
+}
diff --git a/beam.service b/beam.service
new file mode 100644
index 000000000000..bf36738d9305
--- /dev/null
+++ b/beam.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Beam
+After=network.target
+
+[Service]
+ExecStart=/usr/bin/beam -headless
+
+[Install]
+WantedBy=default.target