summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-10-14 09:30:00 -0500
committerLuis Martinez2021-10-14 09:30:00 -0500
commitd1bc56f159d32b02e33271547e1db0711a6d4208 (patch)
tree1aa5437cfd47548a9f19f253c627c74d5e2ab9d0
parentb3648713b26acc1d2d6e98bebae4d3e6252cfeeb (diff)
downloadaur-d1bc56f159d32b02e33271547e1db0711a6d4208.tar.gz
update to 6.1.12023.4694
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
2 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index caf7aa9d01a3..28d62ba26900 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = beam-wallet-bin
pkgdesc = Beam Desktop GUI Wallet
- pkgver = 6.0.11647.433
+ pkgver = 6.1.12023.4694
pkgrel = 1
url = https://beam.mw
arch = x86_64
license = Apache
- source = beam-wallet-bin-6.0.11647.433.tar::https://github.com/BeamMW/beam-ui/releases/download/beam-6.0.11647.4336/Beam-Wallet-6.0.11647.433.tar
- source = beam-wallet-bin-6.0.11647.433.tar.asc::https://github.com/BeamMW/beam-ui/releases/download/beam-6.0.11647.4336/Beam-Wallet-6.0.11647.433.tar.asc
- validpgpkeys = 9FEC539DB8E4EA8B
- sha256sums = ebeac2f165f8ec723cfe1cfc4c3e0a902c3f75f6cfc46ab804938868acd6c3eb
+ source = beam-wallet-bin-6.1.12023.4694.tar::https://github.com/BeamMW/beam-ui/releases/download/beam-6.1.12023.4694/Beam-Wallet-6.1.12023.4694.tar
+ source = beam-wallet-bin-6.1.12023.4694.tar.asc::https://github.com/BeamMW/beam-ui/releases/download/beam-6.1.12023.4694/linux-Beam-Wallet-6.1.12023.4694.tar.asc
+ source = beam-wallet.sh
+ validpgpkeys = A6C62C9F55931860AFF83BBB997EAB9F3DF7F375
+ sha256sums = eb7a19a2169c23561e8d710e22849dcb4ae6a479b04d82102684c0b3f9dac811
sha256sums = SKIP
+ sha256sums = eb87b1db8013d2c6159e943d9f2420ce5a1b8b32e8a2a7c991efb717ce67faad
pkgname = beam-wallet-bin
diff --git a/PKGBUILD b/PKGBUILD
index 007c90641572..651c2aa22030 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,35 @@
-# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Aleksey Barinov
pkgname=beam-wallet-bin
-pkgver=6.0.11647.433
+pkgver=6.1.12023.4694
pkgrel=1
pkgdesc="Beam Desktop GUI Wallet"
arch=('x86_64')
license=('Apache')
url='https://beam.mw'
-source=("$pkgname-$pkgver.tar::https://github.com/BeamMW/beam-ui/releases/download/beam-6.0.11647.4336/Beam-Wallet-$pkgver.tar"
- "$pkgname-$pkgver.tar.asc::https://github.com/BeamMW/beam-ui/releases/download/beam-6.0.11647.4336/Beam-Wallet-$pkgver.tar.asc"
+source=("$pkgname-$pkgver.tar::https://github.com/BeamMW/beam-ui/releases/download/beam-$pkgver/Beam-Wallet-$pkgver.tar"
+ "$pkgname-$pkgver.tar.asc::https://github.com/BeamMW/beam-ui/releases/download/beam-$pkgver/linux-Beam-Wallet-$pkgver.tar.asc"
'beam-wallet.sh')
-sha256sums=('ebeac2f165f8ec723cfe1cfc4c3e0a902c3f75f6cfc46ab804938868acd6c3eb'
+sha256sums=('eb7a19a2169c23561e8d710e22849dcb4ae6a479b04d82102684c0b3f9dac811'
'SKIP'
'eb87b1db8013d2c6159e943d9f2420ce5a1b8b32e8a2a7c991efb717ce67faad')
-validpgpkeys=('9FEC539DB8E4EA8B')
+validpgpkeys=('A6C62C9F55931860AFF83BBB997EAB9F3DF7F375')
+
+PURGE_TARGETS=("opt/$pkgname/"{AppRun,BeamWallet.desktop,beam.png})
prepare() {
- "./BeamWallet-${pkgver}6.AppImage" --appimage-extract &> /dev/null
+ "./Beam-Wallet-$pkgver.AppImage" --appimage-extract &> /dev/null
cd squashfs-root
- sed -i "/Exec/s/\/usr/\/opt\/$pkgname\/usr/" BeamWallet.desktop
+ sed -i "/Exec/s|/usr|/opt/$pkgname/usr|" BeamWallet.desktop
echo "Path=/opt/$pkgname/" >> BeamWallet.desktop
}
package() {
- install -Dm755 beam-wallet.sh "$pkgdir/usr/bin/beam-wallet"
+ install -D beam-wallet.sh "$pkgdir/usr/bin/beam-wallet"
cd squashfs-root
install -Dm644 beam.png -t "$pkgdir/usr/share/icons/hicolor/256x256/apps/"
install -Dm644 BeamWallet.desktop "$pkgdir/usr/share/applications/beam-wallet.desktop"
- rm beam.png BeamWallet.desktop AppRun
install -d "$pkgdir/opt/$pkgname/"
rm -rf usr/share
cp -a --no-preserve=ownership * "$pkgdir/opt/$pkgname/"