summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKirill Goncharov2019-08-21 15:54:11 +0300
committerKirill Goncharov2019-08-22 13:33:20 +0300
commita331dd6b32461a9495d2ff2f85e6b93ce3b8d85b (patch)
tree1865934b64e5d200673e82a053fd2dbe091c4842
downloadaur-a331dd6b32461a9495d2ff2f85e6b93ce3b8d85b.tar.gz
Version 1.2.0
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD17
3 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed59d0b4e5e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = beancount-cryptoassets
+ pkgdesc = Price sources for Beancount that provide prices for various cryptoassets
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/xuhcc/beancount-cryptoassets
+ arch = any
+ license = GPL
+ depends = beancount
+ source = https://github.com/xuhcc/beancount-cryptoassets/archive/v1.2.0.tar.gz
+ sha256sums = 554fcd2004d0ddbcf342ea87c536b1466d0eafa91782c2468b6c8fe2cad054c2
+
+pkgname = beancount-cryptoassets
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c230193ac7b8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0a5bbdfa284
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Kirill Goncharov <kdgoncharov at gmail dot com>
+
+pkgname='beancount-cryptoassets'
+pkgdesc='Price sources for Beancount that provide prices for various cryptoassets'
+pkgver=1.2.0
+pkgrel=1
+arch=('any')
+url="https://github.com/xuhcc/beancount-cryptoassets"
+license=('GPL')
+depends=('beancount')
+source=("https://github.com/xuhcc/beancount-cryptoassets/archive/v${pkgver}.tar.gz")
+sha256sums=('554fcd2004d0ddbcf342ea87c536b1466d0eafa91782c2468b6c8fe2cad054c2')
+
+package () {
+ cd "${pkgname}-${pkgver}"
+ python setup.py install --prefix=/usr --root="${pkgdir}"
+}