summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKirill Goncharov2019-08-15 02:14:07 +0300
committerKirill Goncharov2019-08-22 13:45:48 +0300
commitf21a475da9f63a17c45bc7607cc4370dfc0c559a (patch)
treeb7386f69d9e2f552d912017ece7db40a1ff706da
downloadaur-f21a475da9f63a17c45bc7607cc4370dfc0c559a.tar.gz
Version 2.0.0
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD17
3 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f25d50f34cf4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = beancount-exchangerates
+ pkgdesc = Price source for Beancount that loads data from http://exchangeratesapi.io/
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/xuhcc/beancount-exchangerates
+ arch = any
+ license = GPL
+ depends = beancount
+ source = https://github.com/xuhcc/beancount-exchangerates/archive/v2.0.0.tar.gz
+ sha256sums = 35e12d8ce9c52087e409db27400a3c93c7574cc796b1ecf83359698ac883b282
+
+pkgname = beancount-exchangerates
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c230193ac7b8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..330f60f9b594
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Kirill Goncharov <kdgoncharov at gmail dot com>
+
+pkgname='beancount-exchangerates'
+pkgdesc='Price source for Beancount that loads data from http://exchangeratesapi.io/'
+pkgver=2.0.0
+pkgrel=1
+arch=('any')
+url="https://github.com/xuhcc/beancount-exchangerates"
+license=('GPL')
+depends=('beancount')
+source=("https://github.com/xuhcc/beancount-exchangerates/archive/v${pkgver}.tar.gz")
+sha256sums=('35e12d8ce9c52087e409db27400a3c93c7574cc796b1ecf83359698ac883b282')
+
+package () {
+ cd "${pkgname}-${pkgver}"
+ python setup.py install --prefix=/usr --root="${pkgdir}"
+}