summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2020-07-22 17:13:49 +0300
committerAdrian Perez de Castro2020-07-22 17:13:49 +0300
commitd58cee7dea2be01f9d37decb242a383de58f5fc4 (patch)
treed95e19984318a101f55622a89ca8720f0dc7b3d6
downloadaur-d58cee7dea2be01f9d37decb242a383de58f5fc4.tar.gz
Initial import, replaces beancount-hg
-rw-r--r--.SRCINFO32
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..edcd87246f19
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = beancount-git
+ pkgdesc = Double-Entry Accounting from Text Input
+ pkgver = 2.3.0.r173.g13746c29
+ pkgrel = 1
+ url = http://furius.ca/beancount/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = mercurial
+ makedepends = python-nose
+ makedepends = make
+ depends = python>=3.5
+ depends = mpdecimal
+ depends = python-ply
+ depends = python-dateutil
+ depends = python-magic-ahupp
+ depends = python-beautifulsoup4
+ depends = python-chardet
+ depends = python-bottle
+ depends = python-lxml
+ depends = python-google-api-python-client
+ provides = ledgerhub-hg
+ provides = beancount=2.3.0
+ conflicts = beancount
+ conflicts = beancount-hg
+ replaces = ledgerhub-hg
+ replaces = beancount-hg
+ source = beancount-git::git+https://github.com/beancount/beancount/
+ sha512sums = SKIP
+
+pkgname = beancount-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..218620e2fb38
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!/PKGBUILD
+!/.SRCINFO
+!/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b98901c2a8e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Adrian Perez <aperez@igalia.com>
+pkgname=beancount-git
+pkgdesc='Double-Entry Accounting from Text Input'
+pkgver=2.3.0.r173.g13746c29
+pkgrel=1
+arch=(i686 x86_64)
+url=http://furius.ca/beancount/
+license=(GPL)
+source=("${pkgname}::git+https://github.com/beancount/beancount/")
+sha512sums=('SKIP')
+depends=('python>=3.5' 'mpdecimal' 'python-ply' 'python-dateutil'
+ 'python-magic-ahupp' 'python-beautifulsoup4' 'python-chardet'
+ 'python-bottle' 'python-lxml' 'python-google-api-python-client')
+makedepends=('mercurial' 'python-nose' 'make')
+replaces=(ledgerhub-hg beancount-hg)
+provides=(ledgerhub-hg "beancount=${pkgver%%.r*}")
+conflicts=(beancount beancount-hg)
+
+pkgver() {
+ cd "${pkgname}"
+ (
+ set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+# TODO: Tests are failing at the moment, needs investigating.
+# check () {
+# cd "${pkgname}"
+# export CFLAGS='-std=gnu99'
+# make tests
+# }
+
+package () {
+ cd "${pkgname}"
+ python3 setup.py install --prefix=/usr --root="${pkgdir}"
+}