summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2017-01-06 23:16:54 +0200
committerAdrian Perez de Castro2017-01-06 23:20:33 +0200
commit4031d7bbb69da3f9e29e9b081515cbee9b24c448 (patch)
treeb82d45ce3166339ccfb248a2121190f305b4ddcd
parentf0e656bbdc7a4c866282e7069505091bba009d9e (diff)
downloadaur-4031d7bbb69da3f9e29e9b081515cbee9b24c448.tar.gz
Update dependencies
Also, follow the same scheme as the "beancount" package: python-bottle is a normal depends=, and mpdecimal is added as well.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 22 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bdb400f99734..07e93b99670e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,24 @@
pkgbase = beancount-hg
pkgdesc = Double-Entry Accounting from Text Input
- pkgver = r2826.59cf47a2800a
+ pkgver = r4148.397e821a48c5
pkgrel = 1
url = http://furius.ca/beancount/
arch = i686
arch = x86_64
license = GPL
makedepends = mercurial
- depends = python-dateutil
- depends = python>=3.3
+ makedepends = python-nose
+ makedepends = make
+ depends = python>=3.5
+ depends = mpdecimal
depends = python-ply
depends = python-dateutil
- optdepends = python-bottle: For the "beancount web" web-based interface
+ depends = python-magic-ahupp
+ depends = python-beautifulsoup4
+ depends = python-chardet
+ depends = python-bottle
+ depends = python-lxml
+ depends = python-google-python-api-client
source = beancount-hg::hg+https://bitbucket.org/blais/beancount/
sha1sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d16a53de6384..220d83e93ab1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,29 @@
# Maintainer: Adrian Perez <aperez@igalia.com>
pkgname='beancount-hg'
pkgdesc='Double-Entry Accounting from Text Input'
-pkgver=r2826.59cf47a2800a
+pkgver=r4148.397e821a48c5
pkgrel=1
arch=('i686' 'x86_64')
url="http://furius.ca/beancount/"
license=('GPL')
source=("${pkgname}::hg+https://bitbucket.org/blais/beancount/")
sha1sums=('SKIP')
-depends=('python-dateutil' 'python>=3.3' 'python-ply' 'python-dateutil')
-makedepends=('mercurial')
-optdepends=('python-bottle: For the "beancount web" web-based interface')
+depends=('python>=3.5' 'mpdecimal' 'python-ply' 'python-dateutil'
+ 'python-magic-ahupp' 'python-beautifulsoup4' 'python-chardet'
+ 'python-bottle' 'python-lxml' 'python-google-python-api-client')
+makedepends=('mercurial' 'python-nose' 'make')
pkgver () {
cd "${pkgname}"
printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
}
-build () {
- cd "${pkgname}"
- export CFLAGS='-std=gnu99'
- python3 setup.py build_ext -i
- python3 setup.py build
-}
+# TODO: Tests are failing at the moment, needs investigating.
+# check () {
+# cd "${pkgname}"
+# export CFLAGS='-std=gnu99'
+# make tests
+# }
package () {
cd "${pkgname}"