summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2015-06-20 18:11:12 +0200
committerAdrian Perez de Castro2015-06-20 18:20:20 +0200
commitd2f95db595f311f0016a95c17c2d97b14666dcd6 (patch)
tree69ef838bb015e0b6ed77b71dde589412948abf6d
parent497facb06b1b2e4186274b2ad56414a9a7667453 (diff)
downloadaur-d2f95db595f311f0016a95c17c2d97b14666dcd6.tar.gz
Tidy up dependencies after the last updates to the Beancount code
Namely: - python-cdecimal is not ever needed, instead we depend on Python 3.3 or newer, which guarantees that "import decimal" uses a fast C implementation. - A small Python .so is now built, so "arch" cannot be "any". - python-bottle should be an "optdepends", because most of beancount will happily work without it. It is only needed for the "beancount web" command.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 32df9494116b..72895e1acd62 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = beancount-hg
pkgdesc = Double-Entry Accounting from Text Input
- pkgver = r2586.dbba632103c9
- pkgrel = 1
+ pkgver = r2721.24acbceb37ae
+ pkgrel = 2
url = http://furius.ca/beancount/
- arch = any
+ arch = i686
+ arch = x86_64
license = GPL
makedepends = mercurial
- depends = python-bottle
- depends = wget
+ depends = python-dateutil
+ depends = python>=3.3
+ optdepends = python-bottle: For the "beancount web" web-based interface
source = beancount-hg::hg+https://bitbucket.org/blais/beancount/
sha1sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 137e4077a304..97b019788789 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,16 @@
# Maintainer: Adrian Perez <aperez@igalia.com>
pkgname='beancount-hg'
pkgdesc='Double-Entry Accounting from Text Input'
-pkgver=r2586.dbba632103c9
-pkgrel=1
-arch=('any')
+pkgver=r2721.24acbceb37ae
+pkgrel=2
+arch=('i686' 'x86_64')
url="http://furius.ca/beancount/"
license=('GPL')
source=("${pkgname}::hg+https://bitbucket.org/blais/beancount/")
sha1sums=('SKIP')
-depends=('python-dateutil')
+depends=('python-dateutil' 'python>=3.3')
makedepends=('mercurial')
-
-# TODO: Add python-cdecimal when package is available
-depends=(
- python-bottle
- wget
-)
+optdepends=('python-bottle: For the "beancount web" web-based interface')
pkgver () {
cd "${pkgname}"