summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhuoyun Wei2024-12-30 02:28:02 -0800
committerZhuoyun Wei2024-12-30 02:28:02 -0800
commite6624c56d427b396f975c7ae8216316dd79f4022 (patch)
tree135f2f3b5d7d73788b9951e36dba6000b7475a67
parentd6961041a57a7699151c7892a601b11e3ae4ec5f (diff)
downloadaur-e6624c56d427b396f975c7ae8216316dd79f4022.tar.gz
fix: add dep python-setuptools
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b3492dfb5625..a45d5f3f1609 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = beangulp
pkgdesc = Importers framework for Beancount
pkgver = 0.1.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/beancount/beangulp
arch = any
license = GPL
makedepends = python-build
makedepends = python-installer
makedepends = python-wheel
+ makedepends = python-setuptools
depends = python
depends = beancount>=3
depends = python-beautifulsoup4
diff --git a/PKGBUILD b/PKGBUILD
index 386debf42440..a3a9902f884f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
pkgname=beangulp
pkgdesc='Importers framework for Beancount'
pkgver=0.1.1
-pkgrel=1
+pkgrel=2
arch=("any")
url="https://github.com/beancount/beangulp"
license=('GPL')
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
b2sums=('b5e7015e3a22cd44e5c2b648cf3ba9bfb327f55d43a582d1dae8d7c03d293341f405952ff17b16464cda394ee5acf08aa518b3685e7470c0a630c8accf11ecbc')
depends=("python" "beancount>=3" "python-beautifulsoup4" "python-chardet" "python-click" "python-lxml" "python-magic")
-makedepends=("python-build" "python-installer" "python-wheel")
+makedepends=("python-build" "python-installer" "python-wheel" "python-setuptools")
build() {
cd "${pkgname}-${pkgver}"