summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKristóf Marussy2020-12-28 22:02:24 +0100
committerKristóf Marussy2020-12-28 22:06:50 +0100
commit4dca912838baf1dbdd97a59b9f2ed03c9e2bda9d (patch)
treee06ee791b29b956c245f23398d08048ba8ccb404
downloadaur-4dca912838baf1dbdd97a59b9f2ed03c9e2bda9d.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD35
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ddb55f666cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = beanprice-git
+ pkgdesc = Double-Entry Accounting from Text Input
+ pkgver = 1.0.1.r11.g7614b25
+ pkgrel = 1
+ url = http://furius.ca/beancount/
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = python-pytest
+ depends = python>=3.5
+ depends = beancount>=2.3.1
+ depends = python-dateutil
+ depends = python-requests
+ provides = beanprice=1.0.1
+ conflicts = beanprice
+ source = beanprice-git::git+https://github.com/beancount/beanprice/
+ sha512sums = SKIP
+
+pkgname = beanprice-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..167fa82e9df1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Kristóf Marussy <kristof@marussy.com>
+# Contributor: Adrian Perez <aperez@igalia.com>
+pkgname=beanprice-git
+pkgdesc='Double-Entry Accounting from Text Input'
+pkgver=1.0.1.r11.g7614b25
+pkgrel=1
+arch=(any)
+url=http://furius.ca/beancount/
+license=(GPL)
+source=("${pkgname}::git+https://github.com/beancount/beanprice/")
+sha512sums=('SKIP')
+depends=('python>=3.5' 'beancount>=2.3.1' 'python-dateutil' 'python-requests')
+makedepends=('git' 'python-pytest')
+provides=("beanprice=${pkgver%%.r*}")
+conflicts=(beanprice)
+
+pkgver() {
+ cd "${pkgname}"
+ (
+ set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//' ||
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+ check () {
+ cd "${pkgname}"
+ pytest beanprice
+}
+
+package () {
+ cd "${pkgname}"
+ python3 setup.py install --prefix=/usr --root="${pkgdir}"
+}
+