summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo P2015-08-11 16:43:57 -0400
committerSomeone2015-08-11 16:53:30 -0400
commit68eb39c3fc24f3c20ba5d8cba0022b3ec3c43ac2 (patch)
treed0fb3535fbfe153e0560bbc510fb6762f7e0f2a7
downloadaur-68eb39c3fc24f3c20ba5d8cba0022b3ec3c43ac2.tar.gz
beanstalkd
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD51
-rw-r--r--beanstalkd.conf10
-rw-r--r--beanstalkd.service13
-rw-r--r--beanstalkd@.service13
5 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..680c270f317e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = beanstalkd
+ pkgdesc = Fast, simple message queue server
+ pkgver = 1.10
+ pkgrel = 1
+ arch = i686
+ arch = x86_64
+ license = GPL
+ conflicts = beanstalkd-git
+ backup = etc/conf.d/beanstalkd
+ source = https://github.com/kr/beanstalkd/archive/v1.10.tar.gz
+ source = beanstalkd@.service
+ source = beanstalkd.service
+ source = beanstalkd.conf
+ md5sums = 0994d83b03bde8264a555ea63eed7524
+ md5sums = f6151d5d2f07c24977cafba38a9e67c9
+ md5sums = d05b907abfb19174a7321676ecc0c819
+ md5sums = 7fdc2e3d1dc9c6559b7b007b74588a09
+
+pkgname = beanstalkd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..353c62333f0a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+pkgname=beanstalkd
+pkgver=1.10
+pkgrel=1
+epoch=
+pkgdesc="Fast, simple message queue server"
+arch=('i686' 'x86_64')
+url=""
+license=('GPL')
+depends=()
+makedepends=()
+conflicts=('beanstalkd-git')
+backup=('etc/conf.d/beanstalkd')
+options=()
+install=
+changelog=
+source=("https://github.com/kr/beanstalkd/archive/v${pkgver}.tar.gz"
+ "beanstalkd@.service"
+ "beanstalkd.service"
+ "beanstalkd.conf")
+md5sums=('0994d83b03bde8264a555ea63eed7524'
+ 'f6151d5d2f07c24977cafba38a9e67c9'
+ 'd05b907abfb19174a7321676ecc0c819'
+ '7fdc2e3d1dc9c6559b7b007b74588a09')
+
+
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make CFLAGS="${CFLAGS}"
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" PREFIX="/usr" install
+ #systemd files
+ install -D -m644 "adm/systemd/beanstalkd.socket" "${pkgdir}/usr/lib/systemd/system/beanstalkd.socket"
+ install -D -m644 "${srcdir}/beanstalkd.service" "${pkgdir}/usr/lib/systemd/system/beanstalkd.service"
+ install -D -m644 "${srcdir}/beanstalkd@.service" "${pkgdir}/usr/lib/systemd/system/beanstalkd@.service"
+ install -D -m644 "${srcdir}/beanstalkd.conf" "${pkgdir}/etc/conf.d/beanstalkd"
+
+ install -D -m644 "doc/beanstalkd.1" "${pkgdir}/usr/share/man/man1/beanstalkd.1"
+
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/beanstalkd.conf b/beanstalkd.conf
new file mode 100644
index 000000000000..29aede1c52ce
--- /dev/null
+++ b/beanstalkd.conf
@@ -0,0 +1,10 @@
+## Defaults for the beanstalkd init script, /etc/init.d/beanstalkd on
+## Debian systems.
+
+BEANSTALKD_LISTEN_ADDR=127.0.0.1
+BEANSTALKD_LISTEN_PORT=11300
+
+# You can use BEANSTALKD_EXTRA to pass additional options. See beanstalkd(1)
+# for a list of the available options. Uncomment the following line for
+# persistent job storage.
+#BEANSTALKD_EXTRA="-b /var/lib/beanstalkd" \ No newline at end of file
diff --git a/beanstalkd.service b/beanstalkd.service
new file mode 100644
index 000000000000..bdff878022dc
--- /dev/null
+++ b/beanstalkd.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Simple, fast work queue
+Documentation=man:beanstalkd(1)
+After=network.target
+
+[Service]
+User=nobody
+Group=nobody
+EnvironmentFile=/etc/conf.d/beanstalkd
+ExecStart=/usr/bin/beanstalkd -l ${BEANSTALKD_LISTEN_ADDR} -p ${BEANSTALKD_LISTEN_PORT} $BEANSTALKD_EXTRA
+
+[Install]
+WantedBy=multi-user.target \ No newline at end of file
diff --git a/beanstalkd@.service b/beanstalkd@.service
new file mode 100644
index 000000000000..b6e7e3ad5fe9
--- /dev/null
+++ b/beanstalkd@.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Simple, fast work queue (%i)
+Documentation=man:beanstalkd(1)
+After=network.target
+
+[Service]
+User=nobody
+Group=nobody
+EnvironmentFile=/etc/conf.d/beanstalkd-%i
+ExecStart=/usr/bin/beanstalkd -l ${BEANSTALKD_LISTEN_ADDR} -p ${BEANSTALKD_LISTEN_PORT} $BEANSTALKD_EXTRA
+
+[Install]
+WantedBy=multi-user.target \ No newline at end of file