summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYiyao Yu2021-09-23 21:43:56 -0400
committerYiyao Yu2021-09-23 21:46:28 -0400
commitccc13fb0a0d7749f4b0b8a01dc2a374656b61620 (patch)
tree613e6ff181a0172cdf09789006a9ef821f94b65d
parent98a56c9651265783c309f06eb6301e5aeadece1e (diff)
downloadaur-ccc13fb0a0d7749f4b0b8a01dc2a374656b61620.tar.gz
3.0.15-1: version update
-rw-r--r--.SRCINFO10
-rw-r--r--00-nlohmann-310.patch39
-rw-r--r--PKGBUILD16
3 files changed, 8 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd23e57ea43d..f98e37fcdba5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bear
pkgdesc = tool to generate compilation database for clang tooling
- pkgver = 3.0.13
- pkgrel = 2
+ pkgver = 3.0.15
+ pkgrel = 1
url = https://github.com/rizsotto/Bear
arch = i686
arch = x86_64
@@ -15,9 +15,7 @@ pkgbase = bear
provides = bear
conflicts = bear
conflicts = interception-tools
- source = Bear-3.0.13.tar.gz::https://github.com/rizsotto/Bear/archive/3.0.13.tar.gz
- source = 00-nlohmann-310.patch
- sha256sums = b57d9b139acbbad6439f5b1133266fa5afc5eb095a61cfa07cd9e8941943ae22
- sha256sums = b3c825ccf7544b95e6c842fd2c43b4dded6f6078904f6b08b61f00a01c625a6a
+ source = Bear-3.0.15.tar.gz::https://github.com/rizsotto/Bear/archive/3.0.15.tar.gz
+ sha256sums = a121ef68f58fdd0cc9fade11a98ae87c7d4d69cbf8d05b3c19624095d23b9a39
pkgname = bear
diff --git a/00-nlohmann-310.patch b/00-nlohmann-310.patch
deleted file mode 100644
index e24d6b298a99..000000000000
--- a/00-nlohmann-310.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From c261dc8bb451340ea44e726f339713e55afc23ec Mon Sep 17 00:00:00 2001
-From: Laszlo Nagy <rizsotto@gmail.com>
-Date: Fri, 20 Aug 2021 16:12:54 +1000
-Subject: [PATCH] citnames: fix #396 (new release of json library)
-
----
- source/citnames/source/Output.cc | 2 +-
- third_party/nlohmann_json/CMakeLists.txt | 4 ++--
- 2 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/source/citnames/source/Output.cc b/source/citnames/source/Output.cc
-index 8df1a981..2d004ff6 100644
---- a/source/citnames/source/Output.cc
-+++ b/source/citnames/source/Output.cc
-@@ -184,7 +184,7 @@ namespace cs {
- throw error;
- });
- } else {
-- throw nlohmann::json::out_of_range::create(403, "key 'command' or 'arguments' not found");
-+ throw std::runtime_error("Field 'command' or 'arguments' not found");
- }
-
- validate(entry);
-diff --git a/third_party/nlohmann_json/CMakeLists.txt b/third_party/nlohmann_json/CMakeLists.txt
-index bcd8a052..4621c571 100644
---- a/third_party/nlohmann_json/CMakeLists.txt
-+++ b/third_party/nlohmann_json/CMakeLists.txt
-@@ -9,9 +9,9 @@ else ()
- include(ExternalProject)
- ExternalProject_Add(nlohmann_json_dependency
- URL
-- https://github.com/nlohmann/json/archive/v3.9.1.tar.gz
-+ https://github.com/nlohmann/json/archive/v3.10.0.tar.gz
- URL_HASH
-- MD5=e386222fb57dd2fcb8a7879fc016d037
-+ MD5=78d0f567b2940341704c1d838a11fad2
- DOWNLOAD_NO_PROGRESS
- 1
- UPDATE_COMMAND
diff --git a/PKGBUILD b/PKGBUILD
index 40758e747098..e99472f9aaf2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=bear
_pkgname=Bear
-pkgver=3.0.13
-pkgrel=2
+pkgver=3.0.15
+pkgrel=1
pkgdesc="tool to generate compilation database for clang tooling"
arch=('i686' 'x86_64')
url="https://github.com/rizsotto/Bear"
@@ -13,16 +13,8 @@ makedepends=('cmake' 'ninja' 'nlohmann-json')
depends=('grpc' 'fmt' 'spdlog')
conflicts=('bear' 'interception-tools')
provides=('bear')
-source=("$_pkgname-$pkgver.tar.gz::https://github.com/rizsotto/$_pkgname/archive/$pkgver.tar.gz"
- "00-nlohmann-310.patch")
-sha256sums=('b57d9b139acbbad6439f5b1133266fa5afc5eb095a61cfa07cd9e8941943ae22'
- 'b3c825ccf7544b95e6c842fd2c43b4dded6f6078904f6b08b61f00a01c625a6a')
-prepare() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- for p in ${srcdir}/*.patch; do
- patch -Np1 -i "$p"
- done
-}
+source=("$_pkgname-$pkgver.tar.gz::https://github.com/rizsotto/$_pkgname/archive/$pkgver.tar.gz")
+sha256sums=('a121ef68f58fdd0cc9fade11a98ae87c7d4d69cbf8d05b3c19624095d23b9a39')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"