summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIssam Maghni2019-08-02 20:02:45 -0400
committerIssam Maghni2019-08-02 20:02:45 -0400
commitfe0786a395da623e83593bf75896f1b9ff1fe80c (patch)
tree19dbac698f069152a87bd1b93bf3435a930f44a5
downloadaur-fe0786a395da623e83593bf75896f1b9ff1fe80c.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d93737046bed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = bearssl
+ pkgdesc = Implementation of the SSL/TLS protocol (RFC 5246) written in C
+ pkgver = 0.6
+ pkgrel = 1
+ url = https://bearssl.org
+ arch = x86_64
+ license = MIT
+ depends = glibc
+ source = https://bearssl.org/bearssl-0.6.tar.gz
+ sha256sums = 6705bba1714961b41a728dfc5debbe348d2966c117649392f8c8139efc83ff14
+
+pkgname = bearssl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f85455e96c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Issam Maghni <me dot concati at me>
+
+pkgname=bearssl
+pkgver=0.6
+pkgrel=1
+pkgdesc='Implementation of the SSL/TLS protocol (RFC 5246) written in C'
+arch=('x86_64')
+url='https://bearssl.org'
+depends=('glibc')
+license=('MIT')
+source=("$url/$pkgname-$pkgver.tar.gz")
+sha256sums=('6705bba1714961b41a728dfc5debbe348d2966c117649392f8c8139efc83ff14')
+
+build() {
+ cd "$pkgname-$pkgver"
+ echo CFLAGS ARE "$CFLAGS"
+ make CFLAGS="$CFLAGS -fpic" LDFLAGS="$LDFLAGS" D=.so.$pkgver \
+ LDDLLFLAGS="$LDFLAGS -shared -Wl,-soname,lib$pkgname.so.${pkgver%%.*}"
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin" "$pkgdir/usr/lib" "$pkgdir/usr/share/licenses/$pkgname"
+ cd "$pkgname-$pkgver/build"
+ mv ../LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname"
+ mv ../inc "$pkgdir/usr/include"
+ mv brssl "$pkgdir/usr/bin"
+ mv "lib$pkgname.so.$pkgver" "lib$pkgname.a" "$pkgdir/usr/lib"
+ ln -s "lib$pkgname.so.$pkgver" "$pkgdir/usr/lib/lib$pkgname.so.${pkgver%%.*}"
+ ln -s "lib$pkgname.so.${pkgver%%.*}" "$pkgdir/usr/lib/lib$pkgname.so"
+}