summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2015-06-08 11:10:04 +0200
committerMaxime Gauduin2015-06-08 11:10:04 +0200
commit61f8a9191b3bf2ad395fae57082632f35c083158 (patch)
tree74a41b1a8cee6ce8e38af22dd5aa524e38a2e330
downloadaur-61f8a9191b3bf2ad395fae57082632f35c083158.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD39
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1edaa8213453
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = beat
+ pkgdesc = Delta patcher for the higan emulator
+ pkgver = 03
+ pkgrel = 1
+ url = http://byuu.org/programming/beat/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = gendesk
+ depends = gtk2
+ source = http://byuu.net/files/beat_v03.tar.xz
+ sha256sums = 0f4a33cbbe54af28077433ca9f855e5d80ae942d5d976a0d654a8e1a528a1a1a
+
+pkgname = beat
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb341e32e0ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=beat
+pkgver=03
+pkgrel=1
+pkgdesc='Delta patcher for the higan emulator'
+arch=('i686' 'x86_64')
+url='http://byuu.org/programming/beat/'
+license=('GPL3')
+depends=('gtk2')
+makedepends=('gendesk')
+DLAGENTS=("http::/usr/bin/curl -A 'Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1)' -fLC - --retry 3 --retry-delay 3 -o %o %u")
+source=("http://byuu.net/files/beat_v${pkgver}.tar.xz")
+sha256sums=('0f4a33cbbe54af28077433ca9f855e5d80ae942d5d976a0d654a8e1a528a1a1a')
+
+prepare() {
+ gendesk -n --pkgname 'beat' --pkgdesc "${pkgdesc}" --name='beat' --exec='beat'
+}
+
+build() {
+ cd beat
+
+ make \
+ platform='x' \
+ phoenix='gtk' \
+ compiler='g++' \
+ flags="$CXXFLAGS -I.. -fomit-frame-pointer -std=gnu++11" \
+ link='-s -lX11'
+}
+
+package() {
+ cd beat
+
+ install -dm 755 "${pkgdir}"/usr/{bin,share/applications}
+ install -m 755 beat "${pkgdir}"/usr/bin/beat
+ install -m 644 ../beat.desktop "${pkgdir}"/usr/share/applications/beat.desktop
+}
+
+# vim: ts=2 sw=2 et: