summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authort.sefzick2015-06-08 16:30:30 +0200
committert.sefzick2015-06-08 16:30:30 +0200
commite4f157466317bd8d34cca3f3407a8d7b39c97bf3 (patch)
tree5d38e8579c4590cc119af15fa5b204b9d87c211f
downloadaur-e4f157466317bd8d34cca3f3407a8d7b39c97bf3.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD43
-rw-r--r--beav_on_archlinux.patch61
3 files changed, 121 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d28e5e8ca17
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = beav
+ pkgdesc = Binary Editor And Viewer (with some modifications by the Debian team: release 18)
+ pkgver = 1.40
+ pkgrel = 1
+ url = http://packages.debian.org/stable/beav
+ arch = any
+ license = GPL
+ depends = ncurses
+ source = http://ftp.de.debian.org/debian/pool/main/b/beav/beav_1.40.orig.tar.gz
+ source = http://ftp.de.debian.org/debian/pool/main/b/beav/beav_1.40-18.diff.gz
+ source = beav_on_archlinux.patch
+ md5sums = 9c30dce1697f468682eb2aae464de175
+ md5sums = 63a2f7a63334abc020cd37e86d349ec1
+ md5sums = 9402f42b2e54fa75dd398f213a7bb43a
+
+pkgname = beav
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f26fe4888590
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Thomas Sefzick <t.sefzick@fz-juelich.de>
+pkgname=beav
+pkgver=1.40
+pkgrel=1
+pkgdesc="Binary Editor And Viewer (with some modifications by the Debian team: release 18)"
+_debianpkgrel=18
+url="http://packages.debian.org/stable/beav"
+arch=('any')
+depends=('ncurses')
+license=('GPL')
+source=(http://ftp.de.debian.org/debian/pool/main/b/${pkgname}/${pkgname}_${pkgver}.orig.tar.gz http://ftp.de.debian.org/debian/pool/main/b/${pkgname}/${pkgname}_${pkgver}-${_debianpkgrel}.diff.gz beav_on_archlinux.patch)
+md5sums=('9c30dce1697f468682eb2aae464de175'
+ '63a2f7a63334abc020cd37e86d349ec1'
+ '9402f42b2e54fa75dd398f213a7bb43a')
+
+
+prepare() {
+ _mypkgver=${pkgver/./}
+ cd "$srcdir/beav-$_mypkgver"
+ patch < "$srcdir/beav_${pkgver}-${_debianpkgrel}.diff"
+ patch < "$srcdir/beav_on_archlinux.patch"
+}
+
+build() {
+ _mypkgver=${pkgver/./}
+ cd "$srcdir/beav-$_mypkgver"
+ make
+}
+
+package() {
+ _mypkgver=${pkgver/./}
+ cd "$srcdir/beav-$_mypkgver"
+ chmod 644 beav.1
+ gzip -c beav${_mypkgver}.txt > beav${_mypkgver}.txt.gz
+ chmod 644 beav${_mypkgver}.txt.gz
+ chmod 755 beav
+ mkdir -p $pkgdir/usr/share/man/man1
+ cp -p beav.1 $pkgdir/usr/share/man/man1/.
+ mkdir -p $pkgdir/usr/share/doc/beav
+ cp -p beav${_mypkgver}.txt.gz $pkgdir/usr/share/doc/beav/.
+ mkdir -p $pkgdir/usr/bin
+ cp -p beav $pkgdir/usr/bin/.
+}
diff --git a/beav_on_archlinux.patch b/beav_on_archlinux.patch
new file mode 100644
index 000000000000..c19dfa4d6cb7
--- /dev/null
+++ b/beav_on_archlinux.patch
@@ -0,0 +1,61 @@
+--- basic.c.orig 1994-11-30 18:43:34.000000000 +0100
++++ basic.c 2013-09-14 22:18:42.135823269 +0200
+@@ -9,7 +9,6 @@
+
+ #include "def.h"
+
+-bool move_ptr ();
+ bool forwchar ();
+ bool wind_on_dot ();
+ bool backline ();
+--- def.h.orig 2013-09-14 22:29:34.915800135 +0200
++++ def.h 2013-09-14 22:25:59.249141143 +0200
+@@ -16,6 +16,7 @@
+
+ #ifdef UNIX
+ #include <sys/types.h>
++#include <string.h>
+ #endif /* UNIX */
+
+ #define BACKUP 1 /* Make backup file. */
+--- file.c.orig 2013-09-14 21:33:00.819253652 +0200
++++ file.c 2013-09-14 22:19:30.882488234 +0200
+@@ -10,7 +10,6 @@
+ char load_file ();
+ char readin ();
+ void makename ();
+-bool writeout ();
+ bool parse_f_name ();
+ A32 ffseek ();
+ A32 file_len ();
+--- random.c.orig 2013-09-14 22:19:50.125820880 +0200
++++ random.c 2013-09-14 22:26:45.745806177 +0200
+@@ -73,7 +73,6 @@
+ extern bool dont_repeat;
+ extern BUFFER sav_buf;
+
+-char dec_chr_ok ();
+ ulong get_long ();
+ void wind_on_dot_all ();
+
+--- symbol.c.orig 2013-09-14 21:33:00.822586986 +0200
++++ symbol.c 2013-09-14 22:21:05.975818198 +0200
+@@ -8,7 +8,6 @@
+ #include <string.h>
+ #include "def.h"
+
+-void keyadd ();
+ void keydup ();
+
+
+--- Makefile.orig 2013-09-14 22:57:36.809073985 +0200
++++ Makefile 2013-09-14 22:58:08.075739547 +0200
+@@ -1,6 +1,6 @@
+ # This is the makefile for BSD UNIX
+-#CFLAGS= -g -DUNIX
+-CFLAGS= -g -DUNIX -Wall
++CFLAGS= -g -DUNIX -O
++#CFLAGS= -g -DUNIX -Wall
+ CC=gcc
+
+ OFILES= basic.o ebcdic.o fileio.o region.o text.o wangpc.o \