summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Iooss2016-08-15 20:02:11 +0200
committerAlexandre Iooss2016-08-15 20:02:11 +0200
commit00d5b8690f12e281079894a3ce901e3853a48bfd (patch)
tree0c3bf69c90d148f3a8cf595c9224b079f3c949ce
downloadaur-00d5b8690f12e281079894a3ce901e3853a48bfd.tar.gz
First version with system arsdk3 libs
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore2
-rw-r--r--0001-Use_system_arsdk.patch32
-rw-r--r--LICENSE28
-rw-r--r--PKGBUILD52
5 files changed, 132 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..970c356aa28d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = bebop-stream-vlc-git
+ pkgdesc = Open Parrot Bebop video stream with VLC
+ pkgver = r1.5fd43c3
+ pkgrel = 1
+ url = http://developer.parrot.com/
+ arch = x86_64
+ license = custom
+ makedepends = git
+ depends = libarsdk3-git
+ source = application_notes::git+https://github.com/Parrot-Developers/application_notes
+ source = 0001-Use_system_arsdk.patch
+ source = LICENSE
+ sha256sums = SKIP
+ sha256sums = 9e03f69ae6c41554c60d20738d0bfef391492a386d6ea04f95449e0bcd05842b
+ sha256sums = 1771e95329e9cb2bed04e023e330af3d558d0f13c0c1c5de0581f2880f149deb
+
+pkgname = bebop-stream-vlc-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b15d7921a430
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+application_notes/
+*.pkg.tar.xz
diff --git a/0001-Use_system_arsdk.patch b/0001-Use_system_arsdk.patch
new file mode 100644
index 000000000000..c9bc7f55e4b1
--- /dev/null
+++ b/0001-Use_system_arsdk.patch
@@ -0,0 +1,32 @@
+--- a/application_notes/BebopStreamVLC/Makefile
++++ b/application_notes/BebopStreamVLC/Makefile
+@@ -2,25 +2,17 @@ SRC=$(wildcard *.c)
+ OBJ=$(SRC:.c=.o)
+
+ # Configuration for the current AN
+-LIBS=-larsal -larnetwork -larcommands -lardiscovery -larnetworkal -ljson
++LIBS=-larsal -larnetwork -larcommands -lardiscovery -larnetworkal -ljson-c
+ OUT=BebopDroneStartStream
+
+
+ all: $(OUT)
+
+-$(OUT): check_env $(OBJ)
+- @gcc -o $@ -L$(ARSDK_ROOT)/out/arsdk-native/staging/usr/lib $(OBJ) $(LIBS)
++$(OUT): $(OBJ)
++ @gcc -o $@ $(OBJ) $(LIBS)
+
+ %.o : %.c
+- @gcc -o $@ -I$(ARSDK_ROOT)/out/arsdk-native/staging/usr/include $< -c
+-
+-run : $(OUT)
+- @env LD_LIBRARY_PATH=$(ARSDK_ROOT)/out/arsdk-native/staging/usr/lib ./$(OUT)
+-
+-check_env:
+-ifndef ARSDK_ROOT
+- $(error ARSDK_ROOT not defined. Please define it to the root folder of the SDK before calling this makefile)
+-endif
++ @gcc -o $@ $< -c
+
+ clean:
+ @rm -f $(OUT) $(OBJ)
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..2b9256f4825e
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,28 @@
+Copyright (C) 2014 Parrot SA
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+* Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+* Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in
+ the documentation and/or other materials provided with the
+ distribution.
+* Neither the name of Parrot nor the names
+ of its contributors may be used to endorse or promote products
+ derived from this software without specific prior written
+ permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
+FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
+COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
+INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
+BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS
+OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED
+AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
+OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42a9c47987c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Alexandre Iooss <alexandre.iooss@gmail.com>
+
+pkgname=bebop-stream-vlc-git
+pkgver=r1.5fd43c3
+pkgrel=1
+pkgdesc="Open Parrot Bebop video stream with any video player"
+arch=(x86_64)
+url="http://developer.parrot.com/"
+license=('custom')
+groups=()
+depends=(libarsdk3-git)
+optdepends=()
+makedepends=(git)
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=('application_notes::git+https://github.com/Parrot-Developers/application_notes'
+ '0001-Use_system_arsdk.patch'
+ 'LICENSE')
+sha256sums=('SKIP'
+ '9e03f69ae6c41554c60d20738d0bfef391492a386d6ea04f95449e0bcd05842b'
+ '1771e95329e9cb2bed04e023e330af3d558d0f13c0c1c5de0581f2880f149deb')
+
+pkgver() {
+ cd "$srcdir/application_notes"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir"
+
+ # Patch Makefile
+ patch -p1 -i "$srcdir/0001-Use_system_arsdk.patch"
+}
+
+build() {
+ cd "$srcdir/application_notes/BebopStreamVLC"
+ make
+}
+
+package() {
+ # Copy binary
+ mkdir -p "$pkgdir/usr/bin"
+ cp "$srcdir/application_notes/BebopStreamVLC/BebopDroneStartStream" "$pkgdir/usr/bin/BebopDroneStartStream"
+
+ # Install license
+ mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
+ cp "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}