summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Iooss2016-08-15 20:01:33 +0200
committerAlexandre Iooss2016-08-15 20:01:33 +0200
commitc3e4ee54c143c85d5b0a0b7ce64946e9a543c464 (patch)
tree528f5b6e68879442589a23da5ea9c75b03b38ab1
downloadaur-c3e4ee54c143c85d5b0a0b7ce64946e9a543c464.tar.gz
First version
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore2
-rw-r--r--LICENSE28
-rw-r--r--PKGBUILD55
4 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ce3fa7679b0c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = bebop_mavlink_ctrl-git
+ pkgdesc = Control the Parrot drone using xbox controller with mavlink
+ pkgver = r4.b0c6b78
+ pkgrel = 1
+ url = http://developer.parrot.com/
+ arch = x86_64
+ license = custom
+ makedepends = git
+ depends = libarsdk3-git
+ source = bebop_mavlink_ctrl::git+https://github.com/Parrot-Developers/bebop_mavlink_ctrl
+ source = LICENSE
+ sha256sums = SKIP
+ sha256sums = 1771e95329e9cb2bed04e023e330af3d558d0f13c0c1c5de0581f2880f149deb
+
+pkgname = bebop_mavlink_ctrl-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b0d6a236fd39
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+bebop_mavlink_ctrl/
+*.pkg.tar.xz
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..2b9256f4825e
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,28 @@
+Copyright (C) 2014 Parrot SA
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+* Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+* Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in
+ the documentation and/or other materials provided with the
+ distribution.
+* Neither the name of Parrot nor the names
+ of its contributors may be used to endorse or promote products
+ derived from this software without specific prior written
+ permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
+FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
+COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
+INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
+BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS
+OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED
+AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
+OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b757813a5ba2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Alexandre Iooss <alexandre.iooss@gmail.com>
+
+pkgname=bebop_mavlink_ctrl-git
+pkgver=r4.b0c6b78
+pkgrel=1
+pkgdesc="Control the Parrot drone using xbox controller with mavlink"
+arch=(x86_64)
+url="http://developer.parrot.com/"
+license=('custom')
+groups=()
+depends=(libarsdk3-git)
+optdepends=()
+makedepends=(git)
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=('bebop_mavlink_ctrl::git+https://github.com/Parrot-Developers/bebop_mavlink_ctrl'
+ 'LICENSE')
+sha256sums=('SKIP'
+ '1771e95329e9cb2bed04e023e330af3d558d0f13c0c1c5de0581f2880f149deb')
+
+pkgver() {
+ cd "$srcdir/bebop_mavlink_ctrl"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/bebop_mavlink_ctrl"
+ git submodule init
+ git submodule update
+}
+
+build() {
+ cd "$srcdir/bebop_mavlink_ctrl/mavlink"
+ python -m pymavlink.tools.mavgen --lang C -o ../out/ message_definitions/v1.0/common.xml
+
+ cd "$srcdir/bebop_mavlink_ctrl"
+ make all tests
+}
+
+package() {
+ # Copy files
+ mkdir -p "$pkgdir/usr/lib/"
+ mkdir -p "$pkgdir/usr/bin/"
+ cp "$srcdir/bebop_mavlink_ctrl/out/libmavlink.so" "$pkgdir/usr/lib/"
+ cp "$srcdir/bebop_mavlink_ctrl/out/test_drone" "$pkgdir/usr/bin/"
+ cp "$srcdir/bebop_mavlink_ctrl/out/test_gcs" "$pkgdir/usr/bin/"
+
+ # Install license
+ mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
+ cp "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}