summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornaoko1010hh2021-07-29 15:29:09 +0900
committernaoko1010hh2021-07-29 15:29:09 +0900
commit72ca9232f6b5a3bfb8b5e2939279df7f0eef1a7b (patch)
treef5d38cb80382122f8f3713b22dcf126265f87de1
downloadaur-72ca9232f6b5a3bfb8b5e2939279df7f0eef1a7b.tar.gz
version to 0.1.4
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD33
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..57e50eca407f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = beditor-bin
+ pkgdesc = Video editing software, Can run on Windows, Linux, and macOS.
+ pkgver = 0.1.4
+ pkgrel = 1
+ url = https://github.com/b-editor/BEditor
+ arch = x86_64
+ license = MIT
+ depends = ffmpeg
+ depends = gstreamer
+ depends = gtk2
+ depends = gtk3
+ depends = harfbuzz
+ depends = hdf5
+ depends = jasper
+ depends = libdc1394
+ depends = libwebp
+ depends = openal
+ depends = openexr
+ depends = tesseract
+ source = https://github.com/b-editor/BEditor/releases/download/v0.1.4/beditor_0.1.4-1_amd64.deb
+ sha512sums = SKIP
+
+pkgname = beditor-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..76dd739843a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname=beditor-bin
+pkgver=0.1.4
+pkgrel=1
+pkgdesc="Video editing software, Can run on Windows, Linux, and macOS."
+arch=('x86_64')
+url="https://github.com/b-editor/BEditor"
+license=('MIT')
+depends=(
+ ffmpeg
+ gstreamer
+ gtk2
+ gtk3
+ harfbuzz
+ hdf5
+ jasper
+ libdc1394
+ libwebp
+ openal
+ openexr
+ tesseract
+)
+
+source=("https://github.com/b-editor/BEditor/releases/download/v${pkgver}/beditor_${pkgver}-1_amd64.deb")
+sha512sums=("SKIP")
+
+package() {
+ bsdtar -xf data.tar.xz -C "${pkgdir}/"
+
+ # Fix Icon Path
+ sed -i "s@Icon=/usr/share/pixmaps/beditor_icon.png@Icon=/usr/share/icons/hicolor/scalable/apps/beditor.png@" "${pkgdir}/usr/share/applications/beditor.desktop"
+ install -Dm644 "${pkgdir}/usr/share/pixmaps/beditor_icon.png" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/beditor.png"
+ rm -r "${pkgdir}/usr/share/pixmaps"
+}