summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2017-11-01 14:31:08 -0700
committerclintval2017-11-01 14:31:08 -0700
commit280e284a4080b5bef562b28eb4915ea5b1613df7 (patch)
tree9f3e0dee480dbbb8e2d8d5d6001ca682a433dfab
downloadaur-280e284a4080b5bef562b28eb4915ea5b1613df7.tar.gz
First commit with PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..342d84e2a332
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = bedtools-git
+ pkgdesc = A powerful toolset for genome arithmetic.
+ pkgver = v2.26.0.r148.gd1953b65
+ pkgrel = 1
+ url = https://github.com/arq5x/bedtools2
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = bash
+ depends = zlib
+ provides = bedtools-git
+ conflicts = bedtools-git
+ source = git+https://github.com/arq5x/bedtools2.git
+ md5sums = SKIP
+
+pkgname = bedtools-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..baa5da4173fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+pkgname=bedtools-git
+pkgver=v2.26.0.r148.gd1953b65
+pkgrel=1
+pkgdesc="A powerful toolset for genome arithmetic."
+arch=('i686' 'x86_64')
+url=https://github.com/arq5x/"${pkgname//-git/}"2
+license=('GPL2')
+depends=('bash' 'zlib')
+provides=('bedtools-git')
+conflicts=('bedtools-git')
+source=(git+https://github.com/arq5x/"${pkgname//-git/}"2.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname//-git/}"2
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}"/"${pkgname//-git/}"2
+ make
+}
+
+check()
+{
+ cd "${srcdir}"/"${pkgname//-git/}"2
+ make test
+}
+
+package()
+{
+ cd "${srcdir}"/"${pkgname//-git/}"2
+ for file in bin/*
+ do
+ install -Dm755 "${file}" "${pkgdir}"/usr/bin/$(basename ${file})
+ done
+}