summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel-Andrew Pollo Guilbert2015-10-17 10:01:40 -0400
committerGabriel-Andrew Pollo Guilbert2015-10-17 10:01:40 -0400
commitd7ac2dc08bb7d4acb3561c40808b09c4ece52307 (patch)
tree5f572f31b8d198a65205d2faa5c5e1587e374ec2
parent8ff844cb7853a56b45eccbbd9489e71be1a14a1c (diff)
downloadaur-d7ac2dc08bb7d4acb3561c40808b09c4ece52307.tar.gz
Update version to 0.10.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
-rw-r--r--bedup-contextlib2.patch50
-rw-r--r--bedup-update-current-rev.patch10
4 files changed, 6 insertions, 77 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ebd3da547ef..7aad72fdb198 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bedup
pkgdesc = Offline deduplication utility for the BTRFS filesystem
- pkgver = 0.9.0
+ pkgver = 0.10.0
pkgrel = 5
url = https://github.com/g2p/bedup
arch = i686
@@ -16,12 +16,8 @@ pkgbase = bedup
depends = python-xdg
depends = python-mako
conflicts = bedup-git
- source = https://pypi.python.org/packages/source/b/bedup/bedup-0.9.0.tar.gz
- source = bedup-contextlib2.patch
- source = bedup-update-current-rev.patch
- md5sums = 7b743397e2186e2540a83c857185c28a
- md5sums = 1795a0ececd0c06ecbf22b0845ba34bb
- md5sums = f5eb55bdd4416aac5ae42be771a81c93
+ source = https://pypi.python.org/packages/source/b/bedup/bedup-0.10.0.tar.gz
+ md5sums = cb30bf4a24936fe95310cad42cec0514
pkgname = bedup
diff --git a/PKGBUILD b/PKGBUILD
index d8761d09819e..48adc0c54a63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: TheNiceGuy <gabrielpolloguilbert@gmail.com>
pkgname=bedup
-pkgver=0.9.0
+pkgver=0.10.0
pkgrel=5
pkgdesc="Offline deduplication utility for the BTRFS filesystem"
arch=('i686' 'x86_64')
@@ -13,20 +13,13 @@ makedepends=('gcc' 'btrfs-progs')
url="https://github.com/g2p/bedup"
conflicts=('vpaint-git')
provides=()
-source=('https://pypi.python.org/packages/source/b/bedup/bedup-0.9.0.tar.gz'
- 'bedup-contextlib2.patch'
- 'bedup-update-current-rev.patch')
-md5sums=('7b743397e2186e2540a83c857185c28a'
- '1795a0ececd0c06ecbf22b0845ba34bb'
- 'f5eb55bdd4416aac5ae42be771a81c93')
+source=("https://pypi.python.org/packages/source/b/bedup/bedup-$pkgver.tar.gz")
+md5sums=('cb30bf4a24936fe95310cad42cec0514')
conflicts=('bedup-git')
build() {
cd "$srcdir/$pkgname-$pkgver"
- patch -p1 -i "$srcdir/bedup-contextlib2.patch"
- patch -p1 -i "$srcdir/bedup-update-current-rev.patch"
-
python setup.py build
}
diff --git a/bedup-contextlib2.patch b/bedup-contextlib2.patch
deleted file mode 100644
index fff7e94ad778..000000000000
--- a/bedup-contextlib2.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-diff -aur bedup-0.9.0.orig/bedup/__main__.py bedup-0.9.0/bedup/__main__.py
---- bedup-0.9.0.orig/bedup/__main__.py 2013-04-19 18:25:13.000000000 +0200
-+++ bedup-0.9.0/bedup/__main__.py 2013-05-16 09:53:48.190419843 +0200
-@@ -27,8 +27,7 @@
- import xdg.BaseDirectory # pyxdg, apt:python-xdg
-
- from collections import defaultdict, OrderedDict
--from contextlib import closing
--from contextlib2 import ExitStack
-+from contextlib import closing, ExitStack
- from sqlalchemy.orm import sessionmaker
- from sqlalchemy.pool import SingletonThreadPool
- from uuid import UUID
-diff -aur bedup-0.9.0.orig/bedup/tracking.py bedup-0.9.0/bedup/tracking.py
---- bedup-0.9.0.orig/bedup/tracking.py 2013-04-20 18:20:23.000000000 +0200
-+++ bedup-0.9.0/bedup/tracking.py 2013-05-16 09:53:30.217053847 +0200
-@@ -28,8 +28,7 @@
- import threading
-
- from collections import defaultdict, namedtuple
--from contextlib import closing, contextmanager
--from contextlib2 import ExitStack
-+from contextlib import closing, contextmanager, ExitStack
- from itertools import groupby
- from sqlalchemy.sql import and_, select, func, literal_column
- from uuid import UUID
-diff -aur bedup-0.9.0.orig/bedup.egg-info/requires.txt bedup-0.9.0/bedup.egg-info/requires.txt
---- bedup-0.9.0.orig/bedup.egg-info/requires.txt 2013-04-20 19:21:42.000000000 +0200
-+++ bedup-0.9.0/bedup.egg-info/requires.txt 2013-05-16 09:42:21.642588851 +0200
-@@ -2,7 +2,6 @@
- cffi >= 0.4.2
- pyxdg
- SQLAlchemy
--contextlib2
-
- [interactive]
--ipdb
-\ No newline at end of file
-+ipdb
-diff -aur bedup-0.9.0.orig/setup.py bedup-0.9.0/setup.py
---- bedup-0.9.0.orig/setup.py 2013-04-20 18:57:10.000000000 +0200
-+++ bedup-0.9.0/setup.py 2013-05-16 09:57:27.247495982 +0200
-@@ -48,7 +48,6 @@
- 'cffi >= 0.4.2',
- 'pyxdg',
- 'SQLAlchemy',
-- 'contextlib2',
- ]
-
- if version_info < (2, 7):
diff --git a/bedup-update-current-rev.patch b/bedup-update-current-rev.patch
deleted file mode 100644
index 7e79739e7582..000000000000
--- a/bedup-update-current-rev.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff --git a/bedup-0.9.0.orig/bedup/migrations.py b/bedup-0.9.0/bedup/migrations.py
-index a5ddce1..8ef8dda 100644
---- a/bedup/migrations.py
-+++ b/bedup/migrations.py
-@@ -49,5 +49,5 @@ def upgrade_schema(engine):
- else:
- current_rev = int(current_rev)
- upgrade_with_range(context, current_rev, REV)
-- context._update_current_rev(current_rev, REV)
-+# context._update_current_rev(current_rev, REV)