summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIain2023-07-30 18:45:36 +0100
committerIain2023-07-30 18:45:36 +0100
commit5acf034d3a94d4c9ad817040a46a7fb8ac6bd45e (patch)
tree1aaeef462819c01616f43410b89baa5ee852799a
parentea48e158b5a77796aaaaaadac1e2f86fb4133ea8 (diff)
downloadaur-5acf034d3a94d4c9ad817040a46a7fb8ac6bd45e.tar.gz
Add compiler flags to fix problems with compilation
As suggested by @dureyes and @FredBezies, we now set both `CfLAGS` and `CXXFLAGS` to contain `-Wno-error` so that compilation can succeed.
-rw-r--r--PKGBUILD35
1 files changed, 18 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 071637b118a2..27e1daf8b5e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Iain Tatch <iain.tatch @ gmail>
pkgname=beebem
pkgver=0.0.13
-pkgrel=1
+pkgrel=2
pkgdesc="BBC Micro Emulator"
arch=('x86_64')
url="http://beebem-unix.bbcmicro.com/"
@@ -16,32 +16,33 @@ backup=()
options=()
install=
source=('http://beebem-unix.bbcmicro.com/download/beebem-0.0.13.tar.gz'
- 'http://beebem-unix.bbcmicro.com/download/beebem-0.0.13_64bit.patch'
- 'http://beebem-unix.bbcmicro.com/download/beebem-0.0.13-keys.patch'
- 'http://beebem-unix.bbcmicro.com/download/beebem-0.0.13_menu_crash.patch')
+ 'http://beebem-unix.bbcmicro.com/download/beebem-0.0.13_64bit.patch'
+ 'http://beebem-unix.bbcmicro.com/download/beebem-0.0.13-keys.patch'
+ 'http://beebem-unix.bbcmicro.com/download/beebem-0.0.13_menu_crash.patch')
noextract=()
md5sums=('44e6edc5c3e5fca9a84e2cddc4bf4858' 'fb4b26c4b0189dbf0407816314a42ec6' '05d373f8c295039b62f9b48cc4dad9fa' '32de835139acabb7b919c18a9ebad830')
-
prepare() {
- msg "Applying patch files ..."
- cd $srcdir
- patch -p0 <beebem-0.0.13_64bit.patch
- patch -p0 <beebem-0.0.13-keys.patch
- patch -p0 <beebem-0.0.13_menu_crash.patch
+ msg "Applying patch files ..."
+ cd $srcdir
+ patch -p0 <beebem-0.0.13_64bit.patch
+ patch -p0 <beebem-0.0.13-keys.patch
+ patch -p0 <beebem-0.0.13_menu_crash.patch
}
build() {
- cd "$pkgname-$pkgver"
- ./configure --enable-econet --prefix=/usr
- make
+ cd "$pkgname-$pkgver"
+ export CFLAGS="-Wno-error"
+ export CXXFLAGS="-Wno-error"
+ ./configure --enable-econet --prefix=/usr
+ make
}
package() {
- cd "$pkgname-$pkgver"
- mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
- cp COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- make prefix="$pkgdir/usr/" install
+ cd "$pkgname-$pkgver"
+ mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
+ cp COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ make prefix="$pkgdir/usr/" install
}
# vim:set ts=2 sw=2 et: