summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2024-02-25 17:44:53 +0100
committerDaniel Peukert2024-02-25 17:44:53 +0100
commit8330fbe993bd3f1f6422760b7fe97ae2a10401bb (patch)
tree78502cfadc874177b9ba98966b99521e8553edfa
parent257057bbd4ef7fcdff348ad559034c383f9f89e7 (diff)
downloadaur-8330fbe993bd3f1f6422760b7fe97ae2a10401bb.tar.gz
Add tests to beekeeper-studio
-rw-r--r--PKGBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 18684c064af3..14ecddfe6782 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -51,6 +51,16 @@ build() {
DEBUG='*' NODE_OPTIONS='--openssl-legacy-provider' yarn run vue-cli-service electron:build
}
+check() {
+ cd "$srcdir/$_sourcedirectory/apps/studio/"
+
+ # Run unit tests
+ yarn run test:unit --ci
+
+ # Not running tests, as they are currently not repeatable and the sqlserver test suite does not work
+ # yarn run test:integration --runInBand --ci --testPathIgnorePatterns=sqlserver.spec.js
+}
+
package() {
# Electron resources
cd "$srcdir/$_sourcedirectory/apps/studio/dist_electron/"