summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2024-01-22 01:21:55 +0100
committerDaniel Peukert2024-01-22 01:21:55 +0100
commitff0079c8142f326e3bf28840a75e96bc4151ec05 (patch)
tree76d72ff01ad27c47dfd30192b4068e8a4f631236
parented7f166d182ddf0096f651e0258c51c346701071 (diff)
downloadaur-ff0079c8142f326e3bf28840a75e96bc4151ec05.tar.gz
Update beekeeper-studio nodejs dep version
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6cf2094bb30..41608da12690 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = beekeeper-studio
pkgdesc = Modern and easy to use SQL client for MySQL, Postgres, SQLite, SQL Server, and more
pkgver = 4.1.13
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://github.com/beekeeper-studio/beekeeper-studio
arch = x86_64
@@ -12,7 +12,7 @@ pkgbase = beekeeper-studio
license = GPL-3.0-only
makedepends = git
makedepends = libxcrypt-compat
- makedepends = nodejs
+ makedepends = nodejs-lts-iron
makedepends = npm
makedepends = python
makedepends = yarn
diff --git a/PKGBUILD b/PKGBUILD
index 420f9412ad1c..18684c064af3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Peukert <daniel@peukert.cc>
pkgname='beekeeper-studio'
pkgver='4.1.13'
-pkgrel='1'
+pkgrel='2'
epoch='1'
pkgdesc='Modern and easy to use SQL client for MySQL, Postgres, SQLite, SQL Server, and more'
# If you're running on pentium4, you have to add it to the arch and source arrays of the electron18-bin AUR dependency
@@ -10,7 +10,7 @@ url="https://github.com/$pkgname/$pkgname"
license=('GPL-3.0-only')
_electronpkg='electron18'
depends=("$_electronpkg")
-makedepends=('git' 'libxcrypt-compat' 'nodejs' 'npm' 'python' 'yarn')
+makedepends=('git' 'libxcrypt-compat' 'nodejs-lts-iron' 'npm' 'python' 'yarn')
source=(
"$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
'electron-launcher.sh'
@@ -38,7 +38,7 @@ prepare() {
# Update node-sass and sass-loader to be compatible with current node and Linux version
cd "$srcdir/$_sourcedirectory/apps/studio/"
- yarn add 'node-sass@8.0.0' 'sass-loader@10.4.1' --ignore-engines
+ yarn add 'node-sass@9.0.0' 'sass-loader@10.5.2' --ignore-engines
# Install dependencies
cd "$srcdir/$_sourcedirectory/"