summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-10-05 12:47:25 +1300
committercaltlgin2020-10-05 12:47:25 +1300
commit9d892bb2750a75aa6fbe28ae9a7ea3021e00a02b (patch)
treefc8b83669083a1769b17669b0e397dfa83bee66f
parent45e3ec1d216343e7560b22b7323340ea0b3e5876 (diff)
downloadaur-9d892bb2750a75aa6fbe28ae9a7ea3021e00a02b.tar.gz
Update to v1.7.5
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD41
3 files changed, 44 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c01d0fc22fb5..73996bf23e5a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,24 @@
pkgbase = beekeeper-studio-bin
- pkgdesc = Cross platform SQL editor and database management app for Windows, Linux, and Mac.
- pkgver = 1.6.10
+ pkgdesc = Modern and easy to use SQL client for MySQL, Postgres, SQLite, SQL Server, and more
+ pkgver = 1.7.5
pkgrel = 1
- url = https://www.beekeeperstudio.io/
+ url = https://www.beekeeperstudio.io
arch = x86_64
license = MIT
- source_x86_64 = https://github.com/beekeeper-studio/beekeeper-studio/releases/download/v1.6.10/beekeeper-studio_1.6.10_amd64.deb
- sha256sums_x86_64 = b18cde6600a7cc069fb5fe08dcac99b8fdd42ba8641e5ed4d9fcc2a0a69ee5e8
+ depends = libappindicator-gtk3
+ depends = libnotify
+ depends = libsecret
+ depends = libxss
+ depends = libxslt
+ depends = nodejs
+ depends = nss
+ depends = xdg-utils
+ provides = beekeeper-studio
+ conflicts = beekeeper-studio
+ source = https://github.com/beekeeper-studio/beekeeper-studio/releases/download/v1.7.5/beekeeper-studio_1.7.5_amd64.deb
+ source = beekeeper-studio-1.7.5-LICENSE::https://github.com/beekeeper-studio/beekeeper-studio/raw/master/LICENSE.md
+ sha256sums = 13da76eb871a549ef8876681351f1a9edec7460d5152bbda68b5e49cf6430638
+ sha256sums = 787ebc78ce29cd0cea3e52651936df7fef96b117782882fce389c3b7ce5683f5
pkgname = beekeeper-studio-bin
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 9db0d96e8d2c..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
-pkg
-src
-*.tar.xz
-*.deb
diff --git a/PKGBUILD b/PKGBUILD
index f6d6eac7305e..95bf15998a65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,33 @@
-# Maintainer: Michael Lutonsky <m@luto.at>
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Contributor: Michael Lutonsky <m@luto.at>
-pkgname=beekeeper-studio-bin
-pkgver=1.6.10
+_name_upper='Beekeeper Studio'
+_pkgname='beekeeper-studio'
+pkgname="${_pkgname}-bin"
+pkgver=1.7.5
pkgrel=1
-pkgdesc="Cross platform SQL editor and database management app for Windows, Linux, and Mac."
+pkgdesc='Modern and easy to use SQL client for MySQL, Postgres, SQLite, SQL Server, and more'
arch=('x86_64')
-url="https://www.beekeeperstudio.io/"
+url='https://www.beekeeperstudio.io'
+_url_source='https://github.com/beekeeper-studio/beekeeper-studio'
license=('MIT')
-source_x86_64=("https://github.com/beekeeper-studio/beekeeper-studio/releases/download/v${pkgver}/beekeeper-studio_${pkgver}_amd64.deb")
-sha256sums_x86_64=('b18cde6600a7cc069fb5fe08dcac99b8fdd42ba8641e5ed4d9fcc2a0a69ee5e8')
+depends=('libappindicator-gtk3' 'libnotify' 'libsecret' 'libxss' 'libxslt' 'nodejs' 'nss' 'xdg-utils')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_url_source}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_amd64.deb"
+ "${_pkgname}-${pkgver}-LICENSE::${_url_source}/raw/master/LICENSE.md")
+# NB: updpkgsums: LICENSE == SKIP
+sha256sums=('13da76eb871a549ef8876681351f1a9edec7460d5152bbda68b5e49cf6430638'
+ '787ebc78ce29cd0cea3e52651936df7fef96b117782882fce389c3b7ce5683f5')
-
-package () {
- cd ${pkgdir}
- tar -xf ${srcdir}/data.tar.xz
-
- mkdir -p "${pkgdir}/usr/bin"
- ln -s "/opt/Beekeeper Studio/beekeeper-studio" "${pkgdir}/usr/bin"
+package() {
+ tar -xvf data.tar.xz -C "${pkgdir}"
+ rm -rf "${pkgdir}/usr/share/doc"
+ install -d "${pkgdir}/usr/bin"
+ ln -sf "/opt/${_name_upper}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${_pkgname}" \
+ "${pkgdir}/opt/${_name_upper}/"{'LICENSE.electron.txt','LICENSES.chromium.html'}
+ install -Dm644 "${_pkgname}-${pkgver}-LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
}
+
+# vim: ts=2 sw=2 et: