summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGavin Yancey2020-09-01 00:56:08 -0700
committerGavin Yancey2020-09-01 00:56:08 -0700
commit69f3503398a45e9bea2cd204960bda7cc8915f25 (patch)
treebc421df42fb3412394ab32c7472d0f8a66f5660d
downloadaur-69f3503398a45e9bea2cd204960bda7cc8915f25.tar.gz
Initial commit -- this seems to work
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD30
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc6b0a037328
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = bees
+ pkgdesc = Best-Effort Extent-Same, a btrfs deduplicator daemon
+ pkgver = 0.6.3
+ pkgrel = 1
+ url = https://github.com/Zygo/bees
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = make
+ makedepends = gcc
+ makedepends = markdown
+ makedepends = btrfs-progs
+ source = bees-0.6.3.tar.gz::https://github.com/Zygo/bees/archive/v0.6.3.tar.gz
+ sha256sums = 874969b9198867652364c3149f214f39bdfe0efed67d279c6b77b37765661e54
+
+pkgname = bees
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f0a273054b8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/*.tar.xz
+/*.tar.gz
+/*.tar.zst
+/pkg
+/src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..49d88a130d14
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Gavin Yancey <gyancey@hmc.edu>
+# Contributor: Timofey Titovets <nefelim4ag@gmail.com>
+
+pkgname=bees
+pkgver=0.6.3
+pkgrel=1
+pkgdesc="Best-Effort Extent-Same, a btrfs deduplicator daemon"
+arch=('x86_64')
+url="https://github.com/Zygo/bees"
+license=('GPL3')
+depends=()
+makedepends=('git' 'make' 'gcc' 'markdown' 'btrfs-progs')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/Zygo/bees/archive/v${pkgver}.tar.gz")
+sha256sums=('874969b9198867652364c3149f214f39bdfe0efed67d279c6b77b37765661e54')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make BEES_VERSION="v${pkgver}"
+ make scripts BEES_VERSION="v${pkgver}"
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make install DESTDIR="${pkgdir}" BEES_VERSION="v${pkgver}"
+
+ if grep "$pkgname" "${pkgdir}/usr/bin/beesd"; then
+ exit 1
+ fi
+}