summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrainDamage2019-11-20 12:05:16 +0100
committerBrainDamage2019-11-20 12:06:10 +0100
commit10bda836690ba91f8f20b15a8c2a12d896a31a00 (patch)
tree5767bf4dcc363b4192f16f1f53adaae6b33baaa3
downloadaur-10bda836690ba91f8f20b15a8c2a12d896a31a00.tar.gz
initial version
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f1b535c38cb9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = beets-bandcamp
+ pkgdesc = Plugin for beets to use bandcamp as an autotagger source.
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = https://github.com/unrblt/beets-bandcamp
+ arch = any
+ license = GPL
+ makedepends = python-setuptools
+ depends = python
+ depends = python-six
+ depends = beets
+ depends = python-requests
+ depends = python-beautifulsoup4
+ depends = python-isodate
+ source = https://github.com/unrblt/beets-bandcamp/archive/v0.1.3.tar.gz
+ sha256sums = 250ae2845bbbc1577efff786e95739e49c1382de92881576445d3e6ac75d01f4
+
+pkgname = beets-bandcamp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd9228a452ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+#maintainer BrainDamage
+pkgname=beets-bandcamp
+pkgver=0.1.3
+pkgrel=1
+pkgdesc='Plugin for beets to use bandcamp as an autotagger source.'
+arch=('any')
+url='https://github.com/unrblt/beets-bandcamp'
+license=('GPL')
+depends=('python' 'python-six' 'beets' 'python-requests' 'python-beautifulsoup4' 'python-isodate')
+source=("https://github.com/unrblt/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('250ae2845bbbc1577efff786e95739e49c1382de92881576445d3e6ac75d01f4')
+
+makedepends+=('python-setuptools')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --skip-build --root="${pkgdir}/" --prefix="/usr"
+ #remove __init__.py which is just a copy of beets own plugin init system and would conflict
+ packagesDir="$(python -c 'import site; print(site.getsitepackages()[0])')"
+ pyShortVer="$(python --version | sed s/'Python '/py/ | sed s/'\.[[:digit:]]*$'//)"
+ pyShortestVer="$(python --version | sed s/'Python '// | sed s/'\.[[:digit:]]*$'// | sed s/'\.'// )"
+ sed --in-place /__init__.py/d "${pkgdir}${packagesDir}/beets_bandcamp-${pkgver}-${pyShortVer}.egg-info/SOURCES.txt"
+ rm "${pkgdir}${packagesDir}/beetsplug/__init__.py"
+ rm "${pkgdir}${packagesDir}/beetsplug/__pycache__/__init__.cpython-${pyShortestVer}.pyc"
+} \ No newline at end of file