summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Sampson2015-06-25 21:19:44 -0700
committerAdrian Sampson2015-06-25 21:19:44 -0700
commit69f675311b462fbd2177e67893da196162742e3d (patch)
treefb17f993d3ef5bc0e791c37c2696e995de403cb1
downloadaur-69f675311b462fbd2177e67893da196162742e3d.tar.gz
Migrate from old AUR
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD40
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb9640224af7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = beets-git
+ pkgdesc = Flexible music library manager and tagger - git version
+ pkgver = 1.3.11.r31.ga0ff517
+ pkgrel = 1
+ url = http://beets.radbox.org/
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python2-munkres
+ depends = mutagen
+ depends = python2-setuptools
+ depends = python2-unidecode
+ depends = python2-musicbrainzngs
+ depends = python2-yaml
+ depends = python2-enum34
+ depends = python2-jellyfish
+ optdepends = python2-pyacoustid: acoustic fingerprinting
+ optdepends = python2-flask: web interface
+ optdepends = gstreamer0.10-python: BPD audio player plugin
+ optdepends = python2-pylast: lastgenre plugin
+ provides = beets
+ conflicts = beets
+ source = git://github.com/sampsyo/beets.git
+ md5sums = SKIP
+
+pkgname = beets-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e0d739bec0a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Adrian Sampson <adrian@radbox.org>
+# Contributor: Johannes Löthberg <demizide@gmail.com>
+
+pkgname=beets-git
+pkgver=1.3.11.r31.ga0ff517
+pkgrel=1
+pkgdesc="Flexible music library manager and tagger - git version"
+arch=('any')
+url="http://beets.radbox.org/"
+license=('MIT')
+depends=('python2-munkres' 'mutagen'
+ 'python2-setuptools' 'python2-unidecode'
+ 'python2-musicbrainzngs' 'python2-yaml'
+ 'python2-enum34' 'python2-jellyfish')
+makedepends=('git')
+optdepends=('python2-pyacoustid: acoustic fingerprinting'
+ 'python2-flask: web interface'
+ 'gstreamer0.10-python: BPD audio player plugin'
+ 'python2-pylast: lastgenre plugin')
+provides=('beets')
+conflicts=('beets')
+source=('git://github.com/sampsyo/beets.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/beets
+ git describe --long --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd ${srcdir}/beets
+ python2 setup.py build
+}
+
+package() {
+ cd ${srcdir}/beets
+ python2 setup.py install --root=${pkgdir} --optimize=1
+
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}