summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederik “Freso” S. Olesen2017-01-11 13:33:26 +0100
committerFrederik “Freso” S. Olesen2017-01-11 13:33:26 +0100
commitd710fb89438a7810eabd83f35b699c798faa38bc (patch)
treec9d5a72dc8e8cf249d77a0a5f6d9a18edc8dee22
parentda28ee41c749303d3fc1c23e011beddb4041f835 (diff)
parentfdf56d66aff9c895b2ca1fd401fb53efee97406b (diff)
downloadaur-d710fb89438a7810eabd83f35b699c798faa38bc.tar.gz
Merge beets-python3-git into beets-git.
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD21
2 files changed, 22 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52f5bc517a7e..51e235b0c2cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,19 +6,18 @@ pkgbase = beets-git
arch = any
license = MIT
makedepends = git
- depends = python2-munkres
- depends = mutagen
- depends = python2-setuptools
- depends = python2-unidecode
- depends = python2-musicbrainzngs
- depends = python2-yaml
- depends = python2-enum34
- depends = python2-jellyfish
- depends = python2-six
- optdepends = python2-pyacoustid: acoustic fingerprinting
- optdepends = python2-flask: web interface
- optdepends = python2-gobject: BPD audio player plugin
- optdepends = python2-pylast: lastgenre plugin
+ depends = python-munkres
+ depends = python-mutagen
+ depends = python-setuptools
+ depends = python-unidecode
+ depends = python-musicbrainzngs
+ depends = python-yaml
+ depends = python-jellyfish
+ depends = python-six
+ optdepends = python-pyacoustid: acoustic fingerprinting
+ optdepends = python-flask: web interface
+ optdepends = python-gobject: BPD audio player plugin
+ optdepends = python-pylast: lastgenre plugin
provides = beets
conflicts = beets
source = git+https://github.com/beetbox/beets.git
diff --git a/PKGBUILD b/PKGBUILD
index c9aaa125eb23..bd020e8cdf96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,16 +8,15 @@ pkgdesc="Flexible music library manager and tagger - git version"
arch=('any')
url="http://beets.io/"
license=('MIT')
-depends=('python2-munkres' 'mutagen'
- 'python2-setuptools' 'python2-unidecode'
- 'python2-musicbrainzngs' 'python2-yaml'
- 'python2-enum34' 'python2-jellyfish'
- 'python2-six')
+depends=('python-munkres' 'python-mutagen'
+ 'python-setuptools' 'python-unidecode'
+ 'python-musicbrainzngs' 'python-yaml'
+ 'python-jellyfish' 'python-six')
makedepends=('git')
-optdepends=('python2-pyacoustid: acoustic fingerprinting'
- 'python2-flask: web interface'
- 'python2-gobject: BPD audio player plugin'
- 'python2-pylast: lastgenre plugin')
+optdepends=('python-pyacoustid: acoustic fingerprinting'
+ 'python-flask: web interface'
+ 'python-gobject: BPD audio player plugin'
+ 'python-pylast: lastgenre plugin')
provides=('beets')
conflicts=('beets')
source=('git+https://github.com/beetbox/beets.git')
@@ -30,12 +29,12 @@ pkgver() {
build() {
cd ${srcdir}/beets
- python2 setup.py build
+ python setup.py build
}
package() {
cd ${srcdir}/beets
- python2 setup.py install --root=${pkgdir} --optimize=1
+ python setup.py install --root=${pkgdir} --optimize=1
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}