summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmiad2015-06-08 14:01:28 +0300
committerAmiad2015-06-08 14:01:28 +0300
commit59fb8f6ae9e4c7cdaf666a7911080bd3b98cebd7 (patch)
treee6f883e159cb11feddb718167a45fdcbd6fc461c
downloadaur-59fb8f6ae9e4c7cdaf666a7911080bd3b98cebd7.tar.gz
import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD23
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f981989018fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = behafucha
+ pkgdesc = Convert English/Hebrew text to Hebrew/English text
+ pkgver = 0.7
+ pkgrel = 6
+ url = https://github.com/ilsh1964/behafucha/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = bc
+ depends = zenity
+ depends = pygtk
+ depends = xsel
+ depends = xvkbd
+ source = https://github.com/ilsh1964/behafucha/archive/v0.7.tar.gz
+ sha256sums = 75d3598b0dc64ec17ddd8c6216e0c33c3922cef2f07259a0c95db026556ae20f
+
+pkgname = behafucha
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b0f303cd353
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Amiad Bareli <amiadb at gmail dot com>
+# Last Contributor: amiad
+pkgname=behafucha
+pkgver=0.7
+pkgrel=6
+pkgdesc="Convert English/Hebrew text to Hebrew/English text"
+arch=('i686' 'x86_64')
+url="https://github.com/ilsh1964/behafucha/"
+license=('GPL')
+depends=(bc zenity pygtk xsel xvkbd)
+source=(https://github.com/ilsh1964/$pkgname/archive/v$pkgver.tar.gz)
+sha256sums=('75d3598b0dc64ec17ddd8c6216e0c33c3922cef2f07259a0c95db026556ae20f')
+
+build() {
+ cd $srcdir/Behafucha-$pkgver/Source/
+ sed -i '1c#!/usr/bin/python2' Behafucha.py
+ sed -i '3c python2 /usr/lib/Behafucha/Behafucha.py' $pkgname
+ install -Dm 755 $pkgname $pkgdir/usr/bin/$pkgname
+ install -Dm 644 Behafucha.py $pkgdir/usr/lib/Behafucha/Behafucha.py
+ install -Dm 644 $pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ install -Dm 644 $pkgname.png $pkgdir/usr/share/pixmaps/$pkgname.png
+}
+